Bug 911986 - Very high power consumption / CPU usage with i915
Very high power consumption / CPU usage with i915
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-16 23:12 EST by Tim Wegener
Modified: 2014-02-05 14:14 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 14:14:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ouput of 'powertop --html' when running with kernel-3.7.7-201.fc18.x86_64 (72.84 KB, text/html)
2013-02-16 23:15 EST, Tim Wegener
no flags Details
Output of 'powertop -html' on F16 where problem does not occur, for comparison. (69.09 KB, text/html)
2013-02-16 23:17 EST, Tim Wegener
no flags Details
Output of 'powertop --html' when running with kernel-3.7.7-201.fc18.x86_64 after things spontaneously came good. (72.66 KB, text/html)
2013-02-16 23:33 EST, Tim Wegener
no flags Details
Screenshot showing unresonable CPU load on system-monitor (1.36 MB, image/png)
2013-05-19 11:58 EDT, oliver
no flags Details
my dmsg output (55.86 KB, application/octet-stream)
2013-05-19 11:58 EDT, oliver
no flags Details

  None (edit)
Description Tim Wegener 2013-02-16 23:12:54 EST
Since upgrading to Fedora 18, the power consumption has been super high, battery life very short, fans running always, temperature very high, mouse laggy etc. The problem is sever enough that the system is only barely usable.
The high drain seems to start upon logging into the desktop environment (cinnamon).

I did not have this problem in Fedora 16.

This video driver is i915.

(Could this be related to Bug 842179?)

# uname -a
Linux unknownb8ac6fc6fb58 3.7.7-201.fc18.x86_64 #1 SMP Tue Feb 12 22:35:01 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

top:

kworker items appear constantly at the top of the list in 'top':

  281 root      20   0     0    0    0 S  32.2  0.0  10:32.34 kworker/0:2                                                                                                      
 2396 root      20   0     0    0    0 R  11.9  0.0   1:17.19 kworker/1:2                                                                     


powertop:

powertop reports very high CPU usage, and abnormally high usage for kWork 	output_poll_execute, and kWork 	i915_hotplug_work_func.


lm_sensors:

# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +25.0°C  (crit = +107.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +72.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +67.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +65.0°C  (high = +86.0°C, crit = +100.0°C)


lspci:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Dell Device 049b
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at e2800000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 8000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915

Packages:

# rpm -q kernel
kernel-3.7.5-201.fc18.x86_64
kernel-3.7.6-201.fc18.x86_64
kernel-3.7.7-201.fc18.x86_64

xorg-x11-drv-intel-2.21.2-1.fc18.x86_64
cinnamon-1.6.7-2.fc18.x86_64
Comment 1 Tim Wegener 2013-02-16 23:13:51 EST
(In reply to comment #0)
...
> (Could this be related to Bug 842179?)


Sorry, I meant: Bug 866212.
Comment 2 Tim Wegener 2013-02-16 23:15:13 EST
Created attachment 698422 [details]
Ouput of 'powertop --html' when running with kernel-3.7.7-201.fc18.x86_64
Comment 3 Tim Wegener 2013-02-16 23:17:29 EST
Created attachment 698423 [details]
Output of 'powertop -html' on F16 where problem does not occur, for comparison.
Comment 4 Tim Wegener 2013-02-16 23:33:13 EST
Created attachment 698424 [details]
Output of 'powertop --html' when running with kernel-3.7.7-201.fc18.x86_64 after things spontaneously came good.

Note that the problem occasionally apparently spontaneously goes away.
Here is an example of what powertop output looks like after this has happened.
Comment 5 Josh Boyer 2013-02-18 11:12:27 EST
It's certainly possible this is related to 866212.

Adam, should we dup?
Comment 6 Daniel Laczi 2013-02-18 11:35:45 EST
Maybe it is not a dup. I had power issues with this kernel and some older ones too, but not with kernels older than 3.7 as mentioned in 866212.

BTW: everything is working fine on my machine with 3.7.8-202.fc18.x86_64 which has just been released.
Comment 7 Tim Wegener 2013-02-22 22:32:49 EST
This has been behaving much better lately, but I've just run into it again.

kernel-3.7.9-201.fc18.x86_64

From powertop:

Summary: 741.7 wakeups/second,  115.5 GPU ops/seconds, 0.0 VFS ops/sec and 103.3

                Usage       Events/s    Category       Description
            399.5 ms/s       3.0        kWork          output_poll_execute
            154.1 ms/s       6.8        Process        [kworker/0:1]
            135.9 ms/s      18.1        kWork          i915_hotplug_work_func
            100.0%                      Device         Audio codec hwC0D0: IDT
            100.0%                      Device         Audio codec hwC0D3: Intel
            100.0%                      Device         Display backlight
             56.6 ms/s       9.4        Process        [kworker/1:0]
              0.2 pkts/s                Device         Network interface: eth0 (
             48.0 ms/s       5.3        Process        [kworker/2:1]
             45.0 ms/s      60.9        Process        /usr/lib64/firefox/firefo
             43.4 ms/s      56.4        Process        /usr/bin/cinnamon
             37.5 ms/s      21.4        Process        /usr/bin/Xorg :0 -backgro
            100.0%                      Device         Radio device: btusb
             19.1 ms/s     112.8        Process        roxterm

I am running the cinnamon DE, and I only had roxterm and firefox open when I ran into this again. I had been browsing the web for a while, and then the mouse lag kicked in, the fans cranked and I saw the above in powertop.

According to the changelog, there was another i915 change in the last kernel update, so I'll try dropping back to the previous version.

It's tricky to say when it's gone though, since it can appear spontaneously after using the computer for a while.
Comment 8 Tim Wegener 2013-02-22 22:55:25 EST
I tried (soft) rebooting into kernel-3.7.8-202.fc18.x86_64 and kernel-3.7.7-201.fc18.x86_64 and the high CPU/extreme mouse lag was still present from login. In fact the keyboard response in the grub boot menu was even very laggy. 

Powering the machine off and on again made the problem go away (thanks, IT crowd!), even booting back into kernel-3.7.9-201.fc18.x86_64.


Note that when I booted in kernel-3.7.8-202.fc18.x86_64 and kernel-3.7.7-201.fc18.x86_64, abrt notified my that they had kernel oopses: "irq 16: nobody cared (try booting with the "irqpoll" option)".
Comment 9 Tim Wegener 2013-03-03 03:28:56 EST
Still a problem on kernel-3.7.9-205.fc18.x86_64.
Comment 10 Tim Wegener 2013-03-07 12:04:17 EST
kernel-3.8.1-201.fc18.x86_64 still happens, e.g. after a few hours of fairly pedestrian web browsing:


Summary: 657.5 wakeups/second,  143.4 GPU ops/seconds, 0.0 VFS ops/sec and 81.9%

                Usage       Events/s    Category       Description
            539.3 ms/s      61.0        kWork          i915_hotplug_work_func
            171.9 ms/s      21.2        Process        [kworker/u:0]
            100.0%                      Device         Audio codec hwC0D0: IDT
            100.0%                      Device         Audio codec hwC0D3: Intel
            100.0%                      Device         Display backlight
             40.6 ms/s     170.0        Process        /usr/lib64/firefox/firefo
             23.3 ms/s      19.1        Process        /usr/bin/Xorg :0 -backgro
Comment 11 Tim Wegener 2013-05-18 22:06:15 EDT
FWIW, I haven't seen this happen on later 3.8.x kernels, so perhaps it has been fixed.

The fan does still run continuously on one system though (HP 6710b Core 2 Duo GMA X3100), which wasn't the case in the past.
Comment 12 oliver 2013-05-19 11:55:05 EDT
I am seeing this problem on my new Dell XPS 13 (that's the latest Project Sputnik laptop, so Ubuntu is running OK on this machine) also under Cinnamon.
(Gnome 3 is not quite as bad, but has also unreasonably large CPU time for Xorg and Gnome Shell).  I attach a screenshot which shows that a single instance of system-monitor gets the system to approximately 200% CPU load!

I will also attach my dmesg output in case this is useful.

Today I installed Fedora 19 prerelease, and it is completely fine.  CPU load close to zero in idle.  Since the prerelease also fixes suspend/resume on the XPS 13, I am staying with prerelease for now (it feels much more stable and mature than F18 on this machine...)

But if it helps fix anything, I could run some tests on F18 if necessary.
Comment 13 oliver 2013-05-19 11:58:07 EDT
Created attachment 750150 [details]
Screenshot showing unresonable CPU load on system-monitor

CPU load fluctuates, this shot is on the low end of what is actually seen.
Comment 14 oliver 2013-05-19 11:58:48 EDT
Created attachment 750151 [details]
my dmsg output
Comment 15 Piruthiviraj Natarajan 2013-11-13 06:34:49 EST
This is happening in my 3rd Gen core i7 laptop with a significant high CPU temp and fans spinning wild while using firefox.

Arch linux behaves a lot better.

Happens in both Fedora 20 Beta and fedora rawhide.
Comment 16 Fedora End Of Life 2013-12-21 06:28:28 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 17 Fedora End Of Life 2014-02-05 14:14:03 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.