Bug 912515 - Unable to update pulseaudio with 32 and 64 bit installed
Unable to update pulseaudio with 32 and 64 bit installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On: 338211
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-18 16:04 EST by Lukas Zapletal
Modified: 2013-12-19 20:33 EST (History)
6 users (show)

See Also:
Fixed In Version: pulseaudio-2.1-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 20:33:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2013-02-18 16:04:35 EST
Transaction Check Error:
  file /usr/bin/padsp conflicts between attempted installs of pulseaudio-utils-2.1-6.fc18.i686 and pulseaudio-utils-2.1-6.fc18.x86_64
Comment 1 Rex Dieter 2013-02-18 16:12:03 EST
I suppose I could backport the fix for bug #891425 for f18's puseaudio-2.1 too (in short, so pulseaudio-utils is no longer multilib'd).
Comment 2 Fedora Update System 2013-02-18 21:56:17 EST
pulseaudio-2.1-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pulseaudio-2.1-7.fc18
Comment 3 Lukas Zapletal 2013-02-19 03:44:53 EST
Thanks! Low priority, the workaround is to uninstall this package and reinstall again.
Comment 4 Fedora Update System 2013-02-19 22:59:43 EST
Package pulseaudio-2.1-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-2.1-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2726/pulseaudio-2.1-7.fc18
then log in and leave karma (feedback).
Comment 5 Rex Dieter 2013-03-01 11:20:57 EST
OK, confirmed packaging is fixed, but...

going back to bug #338211 (~Apr 2008!), turns out pulseaudio-utils gets whitelisted (and forced) to be multilib'd regardless of packaging.

I poked the party responsible for mash/multilib, and the whitelisting should get removed soonish.

Will update here when I know more.
Comment 6 Vasilis Keramidas 2013-03-01 18:34:13 EST
When i tried to install pulseaudio-utils-2.1-7.fc18.i686 while x86_64 is already installed i got

Transaction Check Error:
  file /usr/bin/padsp from install of pulseaudio-utils-2.1-7.fc18.i686 conflicts with file from package pulseaudio-utils-2.1-7.fc18.x86_64
Comment 7 Fedora Update System 2013-12-19 20:33:05 EST
pulseaudio-2.1-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.