This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 338211 - alsa-plugins-pulseaudio needs 32 bit libs on x86_64 platform
alsa-plugins-pulseaudio needs 32 bit libs on x86_64 platform
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 375301 426622 (view as bug list)
Depends On:
Blocks: F8Target 912515
  Show dependency treegraph
 
Reported: 2007-10-18 12:05 EDT by Jost Diederichs
Modified: 2013-03-01 11:29 EST (History)
7 users (show)

See Also:
Fixed In Version: mash-0.5.20-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 09:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Diederichs 2007-10-18 12:05:13 EDT
Description of problem:

there is no package containing 32 bit libs of the alsa-plugins-pulseaudio on the
x86_64 repo. 
In order to get wine sounds to work i forced an install of the
alsa-plugins-pulseaudio.i386 from the i386 repo and got wine apps to play sound. 

Version-Release number of selected component (if applicable):
alsa-plugins-pulseaudio-1.0.14-5.fc8
Comment 1 Frederik Hertzum 2007-10-19 02:44:10 EDT
This is true for all 32 bit binaries on x86_64 installations using PulseAudio --
not just wine. This should be a simple matter of including the package in the
x86_64 repository.

Sound works fine (for all the apps I've tested with) if nothing else uses
PulseAudio.
Comment 2 Julian Sikorski 2007-10-31 15:28:14 EDT
Any updates on this? Since PA is going to be default for F8, it would be nice to
have this fixed.
Comment 3 Max Kanat-Alexander 2007-11-18 02:10:18 EST
Yes, I can confirm that this makes various 32-bit applications unable to play
sound on Fedora 8.

Making this a multilib package (or just shipping the 32-bit libs in the 64-bit
package) would be very helpful.
Comment 4 Max Kanat-Alexander 2007-11-18 04:48:10 EST
*** Bug 375301 has been marked as a duplicate of this bug. ***
Comment 5 Eric Moret 2008-01-20 03:13:45 EST
*** Bug 426622 has been marked as a duplicate of this bug. ***
Comment 6 Eric Moret 2008-01-20 03:16:38 EST
Forgive my ignorance, but I don't know how to make an i386 package available to
the x86_64 repository. Not having a 64 bits box around does not help either. Any
hints as to what needs to happen?
Comment 7 Michel Alexandre Salim 2008-01-20 10:47:06 EST
You need to ask someone in charge of the repositories to mark your package as
multilib, so that the i386 package is added to the x86_64 tree.

Not sure what the exact procedure for doing this is. Mark the bug as CVSNeeded:
?, perhaps.
Comment 8 Kevin Kofler 2008-01-20 10:48:23 EST
I'd suggest talking to rel-eng at fedoraproject.org.
Comment 9 Jason 2008-01-20 12:18:54 EST
Couldn't the 32-bit libs be made available for 64-bit systems in a similar way
to xorg-x11-drv-nvidia-libs-32bit-169.07-4.lvn8.x86_64.rpm in rpm.livna.org?

Afterall, I ran into a similar problem where I needed the 32-bit xorg driver
libs to play World of Warcraft in wine on 64-bit. I found this package in the
64-bit repository over at livna, which corrected my problem nicely.


Comment 10 Kevin Kofler 2008-01-20 13:54:23 EST
Uh, a *-32bit-*.x86_64.rpm is an ugly hack. That's what multilibs are for.
Comment 11 Eric Moret 2008-01-21 15:17:27 EST
Anybody knows how to make a multilibs package?
Comment 12 Michel Alexandre Salim 2008-01-21 16:19:35 EST
As Kevin said, e-mail rel-eng at fedoraproject.org? There is no special thing to
do as a packager to make a package multilib, it's just that the repository
managers have to add the package to their multilib list so the 32-bit version is
added to the 64-bit repositories (x86_64, ppc64)
Comment 13 Mark Slemko 2008-01-25 00:19:36 EST
some additional information related to this: 

an error message is:
The error message ERROR: ld.so: object 'libpulsedsp.so' from LD_PRELOAD cannot
be preloaded: ignored.

On Fedora 8, 64 bit, the ALSA/pulseaudio sound initialization crashes when
loading some games (32 bit) under wine. Since there isn't any corresponding 32
bit library on a 64 bit install. i.e. libpulsedsp.so doesn't exist /usr/lib/
Comment 14 Bill Nottingham 2008-02-14 10:02:26 EST
See bug 376721 - we would like to hear from the maintainers first.
Comment 15 Eric Moret 2008-02-14 10:19:44 EST
Re-Assigning to Lennart
Comment 16 Bill Nottingham 2008-04-11 09:43:04 EDT
Adding alsa plugins to the multilib algorithm in mash, will be in 0.3.4.
Comment 17 Fedora Update System 2010-05-07 13:53:44 EDT
mash-0.5.16-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/mash-0.5.16-1.el5
Comment 18 Fedora Update System 2010-09-28 12:18:45 EDT
mash-0.5.20-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mash-0.5.20-1.el5
Comment 19 Fedora Update System 2010-10-13 01:57:06 EDT
mash-0.5.20-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.