Bug 912529 - Kerkis fonts are not correctly shown in libreoffice
Summary: Kerkis fonts are not correctly shown in libreoffice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 19
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-18 22:06 UTC by Herman Grootaers
Modified: 2013-12-14 03:33 UTC (History)
6 users (show)

Fixed In Version: libreoffice-4.1.3.2-10.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-13 05:08:02 UTC


Attachments (Terms of Use)

Description Herman Grootaers 2013-02-18 22:06:44 UTC
Description of problem:
The kerkis fonts from texlive are not correctly shown in LibreOffice; maybe also in other packages. Occured also in rel 17.

Version-Release number of selected component (if applicable):
started in 17, now also in 18, and maybe in rawhide...

How reproducible:
Always

Steps to Reproduce:
1. Clean install Fedora 18 X64-68
2. Clean install Texlive complete
3. Open LibreOffice and select kerkis
  
Actual results:
Kerkis small caps is selected;
also not all fontfaces are not shown 4 out of 11 confirmed by Font Management
also kerkis small caps is not show by Font Management 

Expected results:
kerkis was expected kerkis medium
also all 11 fontfaces to be shown
also kerkis small caps been shown by Font Management

Additional info:

Comment 1 Caolan McNamara 2013-02-18 23:34:27 UTC
a) what's "font management" ? Do you mean format->character inside LibreOffice ? or something else
b) does this affect only LibreOffice or other packages ?

This *might* be effectively a duplicate of bug#436520 depending on the exact problem.

Comment 2 Herman Grootaers 2013-02-19 04:01:14 UTC
Font Management is the font management program via the path in KDE:

Kickoff Application Launcher --> System Settings --> Font Management

Just tested only for the textprocessors installed, though not for LaTeX.

AbiWord and Caligra Words have 4 fontfaces:

Kerkis,
Kekis-Calligraphic,
Kerkis-SemiBold,
KerkisSans,

Funny thing, while LibreOffice gives Kerkis as Kerkis-SmallCaps, AbiWord and Calligra give the correct fontface for Kerkis.

Also http://www.ctan.org/tex-archive/fonts/greek/kerkis/type1 lists 14 fontfaces, and possible another one

Comment 4 Fedora Update System 2013-12-05 09:25:21 UTC
libreoffice-4.1.3.2-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.1.3.2-10.fc20

Comment 5 Fedora Update System 2013-12-05 09:26:14 UTC
libreoffice-4.1.3.2-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.3.2-10.fc19

Comment 6 Fedora Update System 2013-12-05 21:24:03 UTC
Package libreoffice-4.1.3.2-10.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.3.2-10.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22791/libreoffice-4.1.3.2-10.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-12-11 12:13:24 UTC
libreoffice-4.1.3.2-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.3.2-11.fc19

Comment 8 Fedora Update System 2013-12-13 05:08:02 UTC
libreoffice-4.1.3.2-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-12-14 03:33:43 UTC
libreoffice-4.1.3.2-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.