Bug 9129 - netstat should allow more granularity in --numeric
Summary: netstat should allow more granularity in --numeric
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-04 17:30 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-07 15:10:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add --numeric-* options to netstat (9.52 KB, patch)
2000-02-04 17:31 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2000-02-04 17:30:25 UTC
Netstat only has one option, -n or --numeric, to disable resolution of host
names, user names and port names.  However, in most cases the user only
really cares about disabling host-name resolution, since that's what
usually causes netstat to hang or run slowly.  There should be more
granularity in the selection of what should be disabled.

The enclosed patch adds three options to netstat: --numeric-hosts,
--numeric-ports and --numeric-users, which disables resolution of each of
those without affecting the others.

Comment 1 Jonathan Kamens 2000-02-04 17:31:59 UTC
Created attachment 91 [details]
add --numeric-* options to netstat

Comment 2 Jeff Johnson 2000-10-07 15:08:51 UTC
*** Bug 8920 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2000-10-07 15:10:19 UTC
The duplicate is an ooops, fixing. Dratted bug #'s ...

Comment 4 Jeff Johnson 2000-10-07 16:18:57 UTC
Fixed (patch added) in net-tools-1.57-1. Thanks (again :-) for the patch.

Comment 5 Bernd Eckenfels 2000-10-08 00:46:07 UTC
included your patch in the upstream net-tools CVS, thanks for the contribution.


Note You need to log in before you can comment on or make changes to this bug.