Bug 91432 - quota-3.03-1 doesn't initialize after applying the latest kernel update, that is 2.4.20-13.7
quota-3.03-1 doesn't initialize after applying the latest kernel update, that...
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
: Security
: 91897 (view as bug list)
Depends On: 90914
  Show dependency treegraph
Reported: 2003-05-22 12:12 EDT by Peter
Modified: 2007-03-27 00:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-03 06:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter 2003-05-22 12:12:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
quota-3.03-1 doesn't initialize after applying the latest kernel update, that is
2.4.20-13.7. The error messages and problems were already described in recent
similar bug reports about RH7.3, where upgrading to quota 3.0.6 from RH8 or
newer helps. 
The problem is that in RH 7.2 upgrading is not possible due to failed
dependencies because new versions of quota require glibc 2.3 I tried to install
the more recent quota (3.06 and newer) from RedHat rpm's, but it complained
about the version of GLIBC (2.3 was required to satisfy dependencies, whereas RH
7.2 has 2.2). Building packages from srpms ended up with compile errors
identical to those that appeared when I tried to compile the sources (3.06 and

cc  -o quotacheck quotacheck.o quotacheck_v1.o quotacheck_v2.o quotaops.o
 common.o quotasys.o pot.o quotaio.o quotaio_v1.o quotaio_v2.o
 quotaio_rpc.o quotaio_xfs.o quotaio_generic.o rquota_xdr.o rquota_client.o
 rquota_clnt.o -lext2fs -lcom_err
 quotaio_v1.o: In function `v1_check_file':
 /usr/include/sys/stat.h:364: undefined reference to `_fxstat64'
 collect2: ld returned 1 exit status
 make: *** [quotacheck] Error 1

It seems, the new update of quota from RedHat is necessary for RH 7.2

Version-Release number of selected component (if applicable):
quota-3.03-1 with kernel 2.4.20-13.7

How reproducible:

Steps to Reproduce:
1.Apply the latest kernel update, that is 2.4.20-13.7
2.Reboot the system
3.Note the error messages about initializing quotas

Actual Results:  The error messages about initializing quotas during the boot
process appeared and quota didn't work 

Additional info:

When quota stops working on a system, like mine, with several hundred users,
melicious of unwise people can full up the disks very fast - and this i a
secirity issue.
Comment 1 Mark J. Cox (Product Security) 2003-05-29 12:29:12 EDT
*** Bug 91897 has been marked as a duplicate of this bug. ***
Comment 2 Gilles CHAUVIN 2003-05-31 11:48:27 EDT
This bug is a duplicate of bug #90914.
Comment 3 Arjan van de Ven 2003-06-03 06:16:11 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

Comment 4 Joey Esquibal 2003-12-09 07:29:58 EST
RH7.1 had been working fine with my hosting server but when I applied
the latest kernel v2.4.23 I had experienced the same problem as to
what is indicated in this thread.

Is there any fix for this one. I hope that there would be as for the
vurnerabilities released with 2.4 kernels with the do_break() then it
might compromise our hosting server.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.