Bug 91463 - UPGRADING and README.REDHAT missing from %{docdir}
UPGRADING and README.REDHAT missing from %{docdir}
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: mailman (Show other bugs)
beta1
i386 Linux
high Severity high
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-05-22 16:27 EDT by Jay Berkenbilt
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 18:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified SPEC file to fix this bug (17.76 KB, text/plain)
2003-07-29 12:23 EDT, Michael Lee Yohe
no flags Details

  None (edit)
Description Jay Berkenbilt 2003-05-22 16:27:28 EDT
Description of problem:

/usr/share/doc/mailman-2.1.2 does not contain UPGRADING or README.REDHAT

Version-Release number of selected component (if applicable):

mailmain-2.1.2-1 installed on RedHat 9

Someone just needs to add the appropriate lines under "Install the documentation
files" in the .spec file.  I'd suggest taking a careful look at the
documentation files in the source to decide what files should go there. 
README.REDHAT and UPGRADING are the ones I noticed because those are the ones I
needed to look at.
Comment 1 Jay Berkenbilt 2003-07-26 15:06:43 EDT
This problem is still here in Severn.  It's a trivial fix.  Someone should
really fix this before feature freeze for the next release.
Comment 2 Michael Lee Yohe 2003-07-29 12:22:43 EDT
$ diff -ru mailman.spec.orig mailman.spec
--- mailman.spec.orig	2003-07-29 11:14:24.000000000 -0500
+++ mailman.spec	2003-07-29 11:18:24.000000000 -0500
@@ -40,7 +40,7 @@
 Summary: Mailing list manager with built in Web access.
 Name: mailman
 Version: 2.1.2
-Release: 2
+Release: 3
 Epoch: 3
 Group: Applications/Internet
 Source0: ftp://ftp.gnu.org/pub/gnu/mailman/mailman-%{version}.tgz
@@ -165,6 +165,10 @@
 install -m644
$RPM_BUILD_DIR/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}/README.SENDMAIL
$RPM_BUILD_ROOT%{docdir}
 install -m644
$RPM_BUILD_DIR/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}/README.USERAGENT
$RPM_BUILD_ROOT%{docdir}
 
+# following two lines should fix Bug 91463
+install -m644
$RPM_BUILD_DIR/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}/README.REDHAT
$RPM_BUILD_ROOT%{docdir}
+install -m644
$RPM_BUILD_DIR/${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}/UPGRADING
$RPM_BUILD_ROOT%{docdir}
+
 
 # remove dir/files from $RPM_BUILD_ROOT that we aren't shipping
 rm -rf $RPM_BUILD_ROOT%{varmmdir}/icons
@@ -296,6 +300,9 @@
 %attr(0755 root root) /etc/rc.d/init.d/mailman
 
 %changelog
+* Tue Jul 29 2003 Michael Lee Yohe <michael@yohe.net> 3:2.1.2-3
+- fixed spec file to include two missing doc files (Bug 91463)
+
 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
 - rebuilt

I will attach the actual SPEC file to this bug.  This was based off the latest
3:2.1.2-2 source RPM from Rawhide.
Comment 3 Michael Lee Yohe 2003-07-29 12:23:35 EDT
Created attachment 93225 [details]
Modified SPEC file to fix this bug
Comment 4 John Dennis 2004-09-07 18:02:48 EDT
This was fixed a while ago, must have forgotten to close this bug.

Note You need to log in before you can comment on or make changes to this bug.