Bug 914780 - [abrt] python-bugzilla-0.7.0-2.fc18: bugzilla:588:main:AttributeError: 'NoneType' object has no attribute 'split'
[abrt] python-bugzilla-0.7.0-2.fc18: bugzilla:588:main:AttributeError: 'NoneT...
Status: CLOSED DUPLICATE of bug 889150
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:99148bff2c2a0d508c36d91f1b1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-22 13:24 EST by aristo
Modified: 2013-02-26 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 18:58:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2013-02-22 13:24 EST, aristo
no flags Details
File: core_backtrace (148 bytes, text/plain)
2013-02-22 13:24 EST, aristo
no flags Details
File: environ (2.64 KB, text/plain)
2013-02-22 13:24 EST, aristo
no flags Details

  None (edit)
Description aristo 2013-02-22 13:24:49 EST
Version-Release number of selected component:
python-bugzilla-0.7.0-2.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/bugzilla new
executable:     /usr/bin/bugzilla
kernel:         3.6.10-4.fc18.x86_64
uid:            1000

Truncated backtrace:
bugzilla:588:main:AttributeError: 'NoneType' object has no attribute 'split'

Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 808, in <module>
    main()
  File "/usr/bin/bugzilla", line 588, in main
    data[a] = i.split(',')
AttributeError: 'NoneType' object has no attribute 'split'

Local variables in innermost frame:
a: 'cc'
opt: <Values at 0x15c6560: {'comment': None, 'product': None, 'bug_severity': 'medium', 'bug_file_loc': 'http://', 'component': None, 'short_desc': None, 'outputformat': None, 'priority': 'medium', 'cc': None, 'version': None, 'dependson': None, 'output': 'normal', 'rep_platform': 'All', 'op_sys': 'Linux', 'blocked': None}>
bzclass: <class 'bugzilla.rhbugzilla.RHBugzilla4'>
buglist: []
args: []
i: None
data: {}
required: ['product', 'component', 'version', 'short_desc', 'comment', 'rep_platform', 'bug_severity', 'op_sys', 'bug_file_loc', 'priority']
parser: <optparse.OptionParser instance at 0x15c40e0>
action_parser: <optparse.OptionParser instance at 0x15c5290>
global_opt: <Values at 0x15c5200: {'verbose': None, 'bztype': 'auto', 'bugzilla': 'https://bugzilla.redhat.com/xmlrpc.cgi', 'user': None, 'debug': None, 'cookiefile': None, 'password': None}>
action: 'new'
cookiefile: '/home/ns5/.bugzillacookies'
optional: ['cc', 'blocked', 'dependson']
bz: <bugzilla.rhbugzilla.RHBugzilla4 object at 0x15b2d90>
bzinstance: None
Comment 1 aristo 2013-02-22 13:24:53 EST
Created attachment 701303 [details]
File: backtrace
Comment 2 aristo 2013-02-22 13:24:56 EST
Created attachment 701304 [details]
File: core_backtrace
Comment 3 aristo 2013-02-22 13:24:58 EST
Created attachment 701305 [details]
File: environ
Comment 4 Cole Robinson 2013-02-26 18:58:48 EST
This is fixed in updates-testing, please try

yum --enablerepo=updates-testing update python-bugzilla

*** This bug has been marked as a duplicate of bug 889150 ***

Note You need to log in before you can comment on or make changes to this bug.