Bug 916272 - [RHEL 6] 2013 tzdata updates needed for changes in Chile's DST
Summary: [RHEL 6] 2013 tzdata updates needed for changes in Chile's DST
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tzdata
Version: 6.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 917117 (view as bug list)
Depends On: 912521
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-27 17:05 UTC by Petr Machata
Modified: 2018-12-01 16:55 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 912521
Environment:
Last Closed: 2013-03-14 13:22:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 316473 0 None None None Never
Red Hat Product Errata RHEA-2013:0615 0 normal SHIPPED_LIVE tzdata enhancement update 2013-03-14 18:16:56 UTC

Description Petr Machata 2013-02-27 17:05:33 UTC
+++ This bug was initially created as a clone of Bug #912521 +++

Chile's Government has announced they will extend their summertime again in 2013, much like 2012.

Winter time will come into force on April 27th, Saturday, at 24:00 hs (meaning the clock turns back 60 minuts into April 27th, Saturday, 23:00).

Summer time will come into force on September 7th, Saturday, at 24:00 (meaning the clock will jump 60 minuts forward, into September 8th, Sunday, at 01:00).

Please note that Chile has two timezones, one for continental and Antartica regions, and another one for Easter Islands region. Changes are the same, only that in the latter region, changes take place at 22:00 of the same days (jumping back to 21:00 on April 27th, and forward to 23:00 on September 7th).

Official announcement: http://www.minenergia.cl/ministerio/noticias/generales/gobierno-anuncia-fechas-de-cambio-de-953.html

Official website: http://www.horaoficial.cl/cambio.htm

Steps to reproduce:

# zdump -v 'America/Santiago'  | grep 2013

Actual results:

America/Santiago  Sun Mar 10 02:59:59 2013 UTC = Sat Mar  9 23:59:59 2013 CLST isdst=1 gmtoff=-10800
America/Santiago  Sun Mar 10 03:00:00 2013 UTC = Sat Mar  9 23:00:00 2013 CLT isdst=0 gmtoff=-14400
America/Santiago  Sun Oct 13 03:59:59 2013 UTC = Sat Oct 12 23:59:59 2013 CLT isdst=0 gmtoff=-14400
America/Santiago  Sun Oct 13 04:00:00 2013 UTC = Sun Oct 13 01:00:00 2013 CLST isdst=1 gmtoff=-10800

Expected results:

Changes should take place on April 27th and September 7th, respectively.

--- Additional comment from Petr Machata on 2013-02-19 23:08:20 CET ---

OK, we have about three weeks to push this, so this is not critical for a change.  I'll roll out an update this week.  Upstream is aware.  I'll post a patch tomorrow unless someone else beats me to it.

Comment 2 Petr Machata 2013-03-05 10:10:30 UTC
*** Bug 917117 has been marked as a duplicate of this bug. ***

Comment 3 Tomas Olivares 2013-03-06 17:12:55 UTC
Hi Petr,

Do we have any news regarding this? I've received several calls from customers here asking for the update on the tzdata package.

Sorry for the inconvenience.

Regards,

Tomas Olivares

Comment 4 Jaime Tobar 2013-03-06 17:14:26 UTC
Has been released this yet? We have 2 business days left and the last tzdata errata (RHEA-2013:0182) don't solve this.

Comment 6 Jose Luis Lozoya 2013-03-06 20:03:28 UTC
Hi Petr!!! Is there any possibility to have this rpm finished today is very critic not only for one customer, we have almost 14 Strategics customer in the same situation is very urgent this is now escalated and we need provide answer to our customer what are expectations for get this rpm today.  

Your help on this is very important and I'll be very grateful.

Best regards.

Comment 7 Petr Machata 2013-03-06 23:35:35 UTC
An erratum addressing this problem is being prepared now, and should be available soon.

Comment 15 Firas AlShafei 2013-03-07 21:32:25 UTC
Petr,

This is a critical issue which will start affecting a few hundred of our customers deployments in ~55 hours. 

I can understand the need to verify it seems like we're cutting it kind of close here. Is there an expected ETA on this fix so we can start scheduling resources to deal with it?

On a side note, what happened to the RHEL5 bug #912521? I'm getting access denied errors when trying to access it.

Best regards

Comment 16 Petr Machata 2013-03-08 01:09:49 UTC
(In reply to comment #15) 
> This is a critical issue which will start affecting a few hundred of our
> customers deployments in ~55 hours.

At this stage (RELEASE_PENDING) the bug is not in my hands anymore.  I have no control over when the erratum will actually be released.  It should be soon, but when exactly I don't know.  Red Hat support can provide you with RPM's identical to those that will likely be released with the erratum (but without signatures), if that is acceptable.

Comment 17 Alan 2013-03-08 12:18:33 UTC
I am need this parch for my server, plis free this rpm

Comment 18 sebastian 2013-03-08 12:53:14 UTC
yes, please free de rpm

Comment 19 Jose Luis Ilabaca 2013-03-08 13:53:57 UTC
Please any news of when the package will be available.

Comment 20 Fabio Olive Leite 2013-03-08 15:18:53 UTC
Alan, Sebastian, Jose,

as Petr said, please open a customer support case and the support personnel will be able to get you these packages immediately. The actual errata may still take some time, but we enabled all support associates to provide these packages to customers via support cases.

Thank you!
Fábio Olivé
LATAM GSS/SEG Supervisor

Comment 21 Alain Mazoyer 2013-03-08 19:33:26 UTC
Dear Fabio, I  opened a custommer support case but I did'nt receive any package or link for download it.  Do I need to provide some other information than the bug Nº on the case???

Comment 22 J.H.M. Dassen (Ray) 2013-03-08 19:42:53 UTC
Quoting <http://rhn.redhat.com/errata/RHEA-2013-0615.html>:

Updated tzdata packages that add one enhancement are now available for Red Hat
Enterprise Linux 3, 4, 5 and 6.

The tzdata packages contain data files with rules for various time zones.

This update adds the following enhancement:

* The Chilean Government is extending the period of Daylight Saving Time (DST)
in the year 2013 until April the 27th. Then, Chile Standard Time (CLT) and
Easter Island Standard Time (EAST) will be in effect until September the 7th
when switching again to DST. With this update, the rules used for Chile time
zones have been adjusted accordingly. (BZ#912521, BZ#916272, BZ#916273,
BZ#916274)

All users of tzdata are advised to upgrade to these updated packages, which add
this enhancement.

Comment 23 Fabio Olive Leite 2013-03-08 20:03:30 UTC
(In reply to comment #21)
> Dear Fabio, I  opened a custommer support case but I did'nt receive any
> package or link for download it.  Do I need to provide some other
> information than the bug Nº on the case???

Alain, please send me your support case number via email, I'll check it and ensure you get the packages.

That said, Ray has provided the public errata link above, so by now you should see the updated tzdata packages on RHN.

Regards,
Fábio

Comment 24 Tomas Olivares 2013-03-08 20:10:02 UTC
Just to add what Fabio said, make sure to clean and update your repos before attempting to update:

# yum clean all

# yum update tzdata


That should do it.

Regards,

Tomas Olivares

Comment 25 Lubos Kocman 2013-03-14 13:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0615.html

Comment 26 Red Hat Bugzilla 2013-10-04 00:28:19 UTC
Removing external tracker bug with the id '00799051' as it is not valid for this tracker


Note You need to log in before you can comment on or make changes to this bug.