Bug 916418 - virtio_scsi block performance degradation when block size is 4/8/16 and iodepth is 64
Summary: virtio_scsi block performance degradation when block size is 4/8/16 and iodep...
Status: CLOSED DUPLICATE of bug 1106420
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-28 03:02 UTC by Xiaomei Gao
Modified: 2014-08-18 01:07 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-08-18 00:37:56 UTC


Attachments (Terms of Use)

Comment 2 RHEL Product and Program Management 2013-03-04 06:47:20 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 Fam Zheng 2014-08-15 07:41:21 UTC
The enabling of ioeventfd on 6.6 and 6.5.z makes a huge difference. Testing the sequential read can tell this:

RHEL 6.4
==============================================================
bs         iodepth    jobs       bw         iops       latency
--------------------------------------------------------------
4k         64         1          151        38872      1626


RHEL 6.5
==============================================================
bs         iodepth    jobs       bw         iops       latency
--------------------------------------------------------------
4k         64         1          517        132413     478


RHEL 6.6
==============================================================
bs         iodepth    jobs       bw         iops       latency
--------------------------------------------------------------
4k         64         1          491        125940     503


RHEL 6.6 - but disable ioeventfd
==============================================================
bs         iodepth    jobs       bw         iops       latency
--------------------------------------------------------------
4k         64         1          123        31641      2005


So I think this BZ can be closed. Xiaomei, could you confirm?

Comment 9 Fam Zheng 2014-08-18 00:37:56 UTC

*** This bug has been marked as a duplicate of bug 1123271 ***

Comment 10 Qunfang Zhang 2014-08-18 01:07:27 UTC

*** This bug has been marked as a duplicate of bug 1106420 ***


Note You need to log in before you can comment on or make changes to this bug.