Bug 91651 - eSound makes application or even the Gnome environment hang (VIA VT8233 audio chip)
eSound makes application or even the Gnome environment hang (VIA VT8233 audio...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-05-26 15:38 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 17:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod ( after the incident, when the music was playing ) (1.59 KB, text/plain)
2003-06-21 06:41 EDT, David Balažic
no flags Details
/etc/modules.conf (353 bytes, text/plain)
2003-06-21 06:43 EDT, David Balažic
no flags Details
lspci -vvn output (10.55 KB, text/plain)
2003-06-21 06:44 EDT, David Balažic
no flags Details

  None (edit)
Description Need Real Name 2003-05-26 15:38:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have seen more reports concerning the VT8233 audio chip, like bug 54905 and
all it's duplicates. But those were for previous versions of RedHat Linux, and
they are all closed. Too bad, because I believe there is still a problem. I may
not be the most technical person here but I shall try to be as precise as
possible about it.

The bug manifests itself when you try to play an MP3 through xmms, which is by
default set to use eSound as output. You will hear maybe the first note of the
song (for only a fraction of a second), then sound stops. You then have one
click left, like, when you click the Play button in an attempt to get the music
playing again, it freezes the program entirely. After that, cannot even close
it's window anymore. Anyway, the music plays perfectly with xmms set to use the
OSS Driver plugin which is proof (to me) that eSound is to blame. Also, xmms
does not produce any chatter when started from a gnome-terminal, there are no
error messages or anything.

Another manifestation of what I think is the same bug is when, in Nautilus, you
have the mouse pointer hover over an MP3. mpg321 would normally take care of
playing a fragment of the file. It does not however, even while the musical
emblem is shown over the file icon. When after a few seconds you move the mouse
pointer to the next file, Nautilus will stop responding in much the same way as
xmms does (like I described before). Of course, mpg321 (as downloaded from
freshrpms) is also set to use eSound.

These are very consistent bugs, I can replay them every time. Another thing I
have seen happening was when I had a ¨dead¨ application like xmms, and I tried
to Log out from the menu. My entire Gnome and all active programs would lock up!
Only way out: Ctrl+Alt+Backspace and click Restart at the welcome screen. I
haven't tested this very hard, and dread to try it right now while I'm typing,
so I can't say if it is consistent for any special condition. I could try to
reproduce if so asked.

I have also seen discussion about this on some web forum somewhere. It was all
related to eSound, Gnome and VT8233. The depth of discussion there was not
superb but those people at least came forward with the workaround of not using
eSound, but OSS, Alsa and the likes instead. But that is just not very
practical, eSound being the default audio system for Gnome that all applications
want to use.

I hope someone can make heads and tails of this...

Version-Release number of selected component (if applicable):
esound-0.2.28-4

How reproducible:
Always

Steps to Reproduce:
(see above)

Additional info:
My new system is a NoName PC with a cheap Asrock K7VT2 motherboard which has the
VIA VT8233 audio chipset on board. The CPU is an AMD XP2000+. Operating system
is RedHat Linux 9 (obviously...), which otherwise runs perfectly.

Audio is correctly recognized by redhat-config-soundcard as ¨VT8233 AC97 Audio
Controller¨.

I have installed RedHat like it came from the ISO - no modifications in system
files done by me - just a Personal Desktop setup. Also installed xmms-mp3 and
mpg321 (to name but a few of those applications...) directly from
http://shrike.freshrpms.net/
Comment 1 Sebastien Delestaing 2003-05-27 16:03:34 EDT
Ah ! I'm so happy to learn I'm not alone on this planet to still have problems
with VT8233 AC97 Audio / ESD and Redhat 9.0.
Nothing to add to the detailed bug report really, exact same config, exact same
problem.
Note that when the logout freezes (evrytime esd is running basically), you can
jump to a console ctrl+alt+F1, log as yourself, killall esd, back to X
ctrl+alt+F7, and logout properly.
Note 2: In gnome 1.4 I used to be able to deactivate esd completely, this is not
possible anymore ! Even though I unchecked the "start sound server" option, esd
will start every now and then.
Comment 2 Matthew French 2003-06-18 10:04:52 EDT
I have encountered the same problem. I managed to find a temporary work around
by setting the output buffer size in esd to 4096 instead of 512. XMMS works fine
now, although it takes a while to stop.

This is not an ideal solution, but unfortunately I have not had a chance to
pursue it further.
Comment 3 David Balažic 2003-06-21 06:40:08 EDT
Same problem for me:

RH9 - Shrike

xmms-1.2.7-21.p
esound-0.2.28-4
kernel-2.4.20-8-athlon

Login into X as non-root.
Start xmms from the start menu.
display its playlist window. Press the "Add dir" button
select a dir with some music files.

The first and selected music file is a WAV ( 44kHz stereo 16 bit ).
I click on play and nothing happens. xmms does not respond to input any more.
As root I kill the esd process and xmms comes back to life.
( "kill PID" didn't work , I had to use "kill -9 PID" )

Then configured xmms to use OSS instead if esd and everything worked fine.

Brief sysinfo : VIA VT8377 [KT400 AGP], VIA VT8235, Realtek ALC650 sound chip 
on board
mainboard : Gigabyte GA-7VAXP Ultra
CPU : AMD Athlon XP 2200+

More in the attachments.
Comment 4 David Balažic 2003-06-21 06:41:35 EDT
Created attachment 92516 [details]
lsmod ( after the incident, when the music was playing )
Comment 5 David Balažic 2003-06-21 06:43:07 EDT
Created attachment 92517 [details]
/etc/modules.conf
Comment 6 David Balažic 2003-06-21 06:44:20 EDT
Created attachment 92518 [details]
lspci -vvn output

here is normal lspci output :

00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:0a.0 VGA compatible controller: Silicon Integrated Systems [SiS] 86C326
5598/6326 (rev 0b)
00:0b.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
00:0c.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI] (rev 01)
00:0d.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture
(rev 11)
00:0d.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev
11)
00:0f.0 RAID bus controller: Promise Technology, Inc. PDC20276 IDE (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master
IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio
Controller (rev 50)
00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:14.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
01:00.0 VGA compatible controller: SGS Thomson Microelectronics STG4000 [3D
Prophet Kyro Series] (rev 0f)
Comment 7 Need Real Name 2003-06-26 15:49:12 EDT
Yes, yes, yes, yes, yes.... all of the above.

Plays first note then hangs the system... brutally!!!
Have to resort to extreme measure to get things back to normal.

Also Athlon 1.8GHz processor, DFI 75 mainboard with integrated via82cxxx_audio
Comment 8 Jesper Frickmann 2003-07-16 20:25:48 EDT
I have the same problem with RH 9 on my AOpen AK77-8X mobo. How do you set the
output buffer size in esd? The documentation for esd is not very helpful.
Comment 9 Havoc Pennington 2003-07-30 16:46:59 EDT
If this only happens with the one sound driver, conceivably it's a kernel 
issue. I don't know though.
Comment 10 Alan Cox 2003-07-30 17:16:27 EDT
Fixed in the current errata kernel. ESD asked for zillions of fragments, we said
OK but the hardware has a lower limit.
Comment 11 Havoc Pennington 2003-07-30 17:20:37 EDT
Thanks, moving and closing.

Note You need to log in before you can comment on or make changes to this bug.