Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 916643

Summary: [rhevm] - Upgrade - ovirt-engine-dwhd fails start automatically after upgrade (Upgrade from si25.4 to si27.1)
Product: Red Hat Enterprise Virtualization Manager Reporter: Idith Tal-Kohen <italkohe>
Component: ovirt-engine-dwhAssignee: Yaniv Lavi <ylavi>
Status: CLOSED ERRATA QA Contact: David Botzer <dbotzer>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.1.3CC: acathrow, bazulay, chetan, cpelland, dbotzer, dyasny, iheim, mgoldboi, pstehlik, Rhev-m-bugs, sgrinber, ykaul, ylavi
Target Milestone: ---Keywords: ZStream
Target Release: 3.1.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, it was a requirement to have the Manager running when the database warehouse service started. Consequently, upgrading the rhevm-dwh package produced an error which prevented the database warehouse service from automatically starting. The requirement for a running Manager has been removed, so now rhevm-dwhd starts automatically after upgrade.
Story Points: ---
Clone Of: 913384 Environment:
Last Closed: 2013-03-12 14:16:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 913384    
Bug Blocks:    

Description Idith Tal-Kohen 2013-02-28 15:10:33 UTC
+++ This bug was initially created as a clone of Bug #913384 +++

Created attachment 700378 [details]
dwhd servce down

Description of problem:
Cannot Start DWHd service & Receiving Error Can't start the ovirt-engine-dwhd service when upgrading from si25.4 to si27.1 with reports

Version-Release number of selected component (if applicable):
3.1/si27.1 - si25.4

How reproducible:
always

Steps to Reproduce:
1.Install rhevm30 ic158.2 with reports + dwh
2.aggregate data for 2D
3.Upgrade to rhevm31/si24.5 (3.1.1)
  Upgrade reports & dwh & run setup
4.aggregate data for 2D
5.Upgrade to rhevm31/si27.1 (3.1.3)

  
Actual results:
when rhevm-upgrade finishes service DWHd is stopped & I get error:
* Error: Can't start the ovirt-engine-dwhd service 


Expected results:
dwhD service should start & no error should be displayed

Additional info:
3.1/si25.4 upgraded to si27.1

Is it a known issue ? (Can't start the ovirt-engine-dwhd service)

Would you like to proceed? (yes|no): y
Stopping ovirt-engine service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]
Cleaning async tasks...                                  [ DONE ]
Pre-upgrade validations...                               [ DONE ]
Backing Up Database...                                   [ DONE ]
Rename Database...                                       [ DONE ]
Updating rpms (This may take a while
depending on your connection speed to the repository.
To track the installation process run tail -f /var/log/yum.log in
another session).
Note that the transition from package removal to package installation
is expected
to take a significant amount of time. No output will appear in the log
file during
this transition.... [ DONE ]
Updating Database...                                     [ DONE ]
Restore Database name...                                 [ DONE ]
Running post install configuration...                    [ DONE ]
Starting ovirt-engine...                                 [ DONE ]

RHEV Manager upgrade completed successfully!

* Error: Can't start the ovirt-engine-dwhd service

--- Additional comment from David Botzer on 2013-02-21 10:44:26 EST ---

reproduced also on 
3.2/SF8

I upgraded SF7 to SF8 while dwhd service failed to start automatically,
needs to start manually.

--- Additional comment from David Botzer on 2013-02-21 10:46:07 EST ---

Created attachment 700609 [details]
SF7-SF8

--- Additional comment from Yaniv Dary on 2013-02-25 06:45:12 EST ---

Checked the logs the service did start ok nd had return code 0.
The upgrade returned error anyway. Moving to integration to check upgrade.




Yaniv

--- Additional comment from Yaniv Dary on 2013-02-25 07:54:29 EST ---

Please add log of the dwh post upgrade with the error.



Yaniv

--- Additional comment from David Botzer on 2013-02-25 08:11:32 EST ---

which log ?
see all logs in GZ

--- Additional comment from David Botzer on 2013-02-25 08:12:02 EST ---

Created attachment 702344 [details]
si27.1

--- Additional comment from David Botzer on 2013-02-25 08:22:09 EST ---

Created attachment 702355 [details]
SF-7-SF-8

--- Additional comment from Yaniv Dary on 2013-02-25 08:25:27 EST ---

(In reply to comment #7)
> Created attachment 702355 [details]
> SF-7-SF-8

The files are corrupt.

Comment 2 David Botzer 2013-03-06 16:17:39 UTC
Fixed,
Installed si24.5
Upgraded to si27.4
DWH is up and running automatically
No Error messages during upgrade
Keep saving data in history

I had also upgraded reports+dwh
Ran setup

Fixed,
Upgraded to si27.4

Comment 6 errata-xmlrpc 2013-03-12 14:16:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0637.html