Bug 916697 - qtcurve-gtk2 scrambles gtk2 menus
Summary: qtcurve-gtk2 scrambles gtk2 menus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtcurve-gtk2
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 902547 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-28 17:07 UTC by Dietmar Schnabel
Modified: 2013-03-12 23:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 23:32:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Dietmar Schnabel 2013-02-28 17:07:25 UTC
Description of problem:

In KDE, with the QtCurve widget style applied to GTK apps, hover images are 'scrambled.' That's just a minor annoyance, but this also caused Firefox 18 to crash every time it was closed. (the problem with the firefox crash is meanwhile fixed only the scrambling of the menus is still there)

Version-Release number of selected component (if applicable):

qtcurve-gtk2-1.8.15-2.fc18.src.rpm


How reproducible:

From KDE Use qt-curve as gtk style

Steps to Reproduce:
1.start firefox
2.open any menu
3.see scrambling
  
Actual results:
menu looks bad


Expected results:
menu should be okay

Additional info:

Problem is fixed with the actual version from rawhide: 

 qtcurve-gtk2-1.8.16-1.fc19.src.rpm

see also: http://forums.fedoraforum.org/showthread.php?t=287755

Comment 1 Dietmar Schnabel 2013-03-01 07:45:35 UTC
The problem might also have to do with graphic chipset installed as the linked report was also referring to a embedded Intel graphic card and the laptop where this happens for me is  also using a intel chipset.

Interestingly the problem is fixed with the new version of qtcurve-gtk2.

Dietmar

Comment 2 Fedora Update System 2013-03-04 13:53:28 UTC
qtcurve-gtk2-1.8.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.16-1.fc18

Comment 3 Rex Dieter 2013-03-04 13:53:41 UTC
*** Bug 902547 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2013-03-04 22:40:13 UTC
Package qtcurve-gtk2-1.8.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qtcurve-gtk2-1.8.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3420/qtcurve-gtk2-1.8.16-1.fc18
then log in and leave karma (feedback).

Comment 6 Dietmar Schnabel 2013-03-06 18:43:28 UTC
I tested the new version and as expected everything works without problems. Also no side effects on a second PC without Intel Chipset (Nvidia in this case using Nvidia drivers)

Dietmar

Comment 7 Fedora Update System 2013-03-12 23:32:37 UTC
qtcurve-gtk2-1.8.16-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.