Bug 91706 - xfs freshening fails on preinstall script
xfs freshening fails on preinstall script
Status: CLOSED DUPLICATE of bug 91822
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 10:17 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-05-27 10:17:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
sudo rpm -Fvh XFree86-xfs-4.3.0-12.i386.rpm
useradd: user xfs exists
error: %pre(XFree86-xfs-4.3.0-12) scriptlet failed, exit status 9
error:   install: %pre scriptlet failed (2), skipping XFree86-xfs-4.3.0-12

Seems like preinstall contains the following which fails if the user already
exists returning an errorcode ...

/usr/sbin/useradd -c "X Font Server" -r -s $LOGINSHELL -u 43 -d /etc/X11/fs xfs



Version-Release number of selected component (if applicable):
XFree86-xfs-4.3.0-12.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh XFree86-xfs*
2.
3.
    

Actual Results:  Install process aborts

Expected Results:  Shouldn't abort even if user "xfs" exists already (which is
the case with most systems)

Additional info:

The following would probably prevent the error condition (from the top of my head):

/usr/sbin/useradd -c "X Font Server" -r -s $LOGINSHELL -u 43 -d /etc/X11/fs xfs
2> /dev/null || :
Comment 1 Mike A. Harris 2003-05-28 15:06:31 EDT

*** This bug has been marked as a duplicate of 91822 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:53:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.