Bug 91822 - (xfsscript) rawhide xfs rpm will not install
rawhide xfs rpm will not install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 91706 91707 91733 91756 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-28 13:39 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.3.0-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 02:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-28 13:39:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Linux 2.4.20-9 i686) Opera 7.11  
[en]

Description of problem:
# rpm -Uvh XFree86-xfs_4.3.0-12_i386.rpm
Preparing...                ########################################### [100%]
useradd: user xfs exists
error: %pre(XFree86-xfs-4.3.0-12) scriptlet failed, exit status 9
error:   install: %pre scriptlet failed (2), skipping XFree86-xfs-4.3.0-12


Version-Release number of selected component (if applicable):
XFree86-xfs_4.3.0-12_i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. run rpm -Uvh XFree86-xfs_4.3.0-12_i386.rpm
2.
3.
    

Additional info:

I'm using redhat rawhide, using apt-get and ftp.uninett.no as archive.
here is my /etc/apt/sources.list

rpm ftp://ftp.uninett.no/pub/linux/apt redhat/rawhide/en/i386/redhat os
rpm-src ftp://ftp.uninett.no/pub/linux/apt redhat/rawhide/en/i386/redhat os

rpm ftp://ftp.uninett.no/pub/linux/apt redhat/9/en/i386/redhat freshrpms
rpm-src ftp://ftp.uninett.no/pub/linux/apt redhat/9/en/i386/redhat freshrpms
Comment 1 Mike A. Harris 2003-05-28 14:25:54 EDT
This was caused by some cleanups I've been trying to make to the packaging,
in which it isn't clear what all things should stay and what should go.  I
removed something that should stay.  Oops.  ;o)

The next build will have this fixed.  Thanks for reporting it, and if you see
any type of similar problems in other subpackages, etc. please report them
in individual reports too, and I'll try to fix them up ASAP.

Thanks again.
Comment 2 Mike A. Harris 2003-05-28 14:28:44 EDT
Changed script to:

%pre xfs
{
  # Conditionalized to work on RHL 7.1 and 7.2 which do not have /sbin/nologin
  LOGINSHELL=$([ -e /sbin/nologin ] && echo /sbin/nologin || echo /bin/false)
  /usr/sbin/useradd -c "X Font Server" -r -s $LOGINSHELL -u 43 -d /etc/X11/fs
xfs || :
} &> /dev/null || : # Silence output, and ignore errors (Bug #91822)

Comment 3 Mike A. Harris 2003-05-28 15:06:34 EDT
*** Bug 91706 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2003-05-28 15:06:47 EDT
*** Bug 91707 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-05-28 15:07:05 EDT
*** Bug 91733 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2003-05-28 15:07:29 EDT
*** Bug 91756 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2003-05-29 02:42:59 EDT
Fixed in 4.3.0-13

Note You need to log in before you can comment on or make changes to this bug.