Bug 91783 - no tty-based aumix?
no tty-based aumix?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: aumix (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
: 91362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-28 00:48 EDT by Jonathan Kamens
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 23:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-05-28 00:48:44 EDT
I have both aumix-2.8-1 and aumix-X11-2.8-1 installed.  Used to be, if I ran
"aumix" I got the curses version, which is what I want.  Now, "aumix" gets me
the X version and I can't find any way to get the TTY version instead.  E.g.,
when I do "DISPLAY= aumix" it complains that it can't open the display.

There ought to be a way, as there was before, to use the curses version of aumix
even when the X version is also installed.
Comment 1 Mike A. Harris 2003-05-28 17:30:51 EDT
It's some mishap that occured when updating from 2.7 to 2.8.  I haven't
investigated it yet, but plan on fixing it in the future.  I'll diff my
changes and see if I messed something up, or if there has been some upstream
change that resulted in this.  Possibly both.

Thanks.
Comment 2 Mike A. Harris 2003-05-28 17:32:49 EDT
*** Bug 91362 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2003-05-29 22:00:56 EDT
You're supposed to run "xaumix" to get curses version in X.  I think this is
stupid though.  Run "aumix" in the Linux console and you get the text version.
I dunno what the author was thinking here.

IMHO, "aumix" should *ALWAYS* give the text mode console version of aumix,
and xaumix or aumix-X11 should give the GUI version (or why have them).

Why this changed from version 2.7 to 2.8 is beyond me.
Comment 4 Jonathan Kamens 2003-05-29 22:20:37 EDT
Run a program whose name starts with "x" to get the non-X version of it?  That's
just silly.

It doesn't even work -- sure, it puts up the old-style interface, but in a new
window!  I just want what I had before -- when I run aumix, I want a curses
interface in the window from which I ran it.
Comment 5 Jonathan Kamens 2003-05-29 22:21:17 EDT
And I realize this isn't your fault Mike :-).
Comment 6 Mike A. Harris 2003-05-29 22:38:37 EDT
Yep, I agree, the new behaviour is rediculous, and it needs to change back.
It is totally non-intuitive.

"aumix" should give the text based curses aumix that always occured before.

Acceptable ways of getting the GUI would be:

aumix --gui
xaumix
aumix-X11

The way things are now, it is just retarded.  Even having an "aumix --nox"
would make sense.  I had to run "aumix -C ansi" to get what you want.

I'm going to probably remove the GUI version entirely as we have 10000 GUI
mixers already, and the sole purpose aumix exists in Red Hat Linux is to
provide a console ncurses mixer and save/restore mixer settings.

I regret having updated to aumix 2.8 now.  I'll either hack the snot out of
it to obtain the desired behaviour or drop back to 2.7 which works.
Comment 7 Mike A. Harris 2003-05-29 23:11:16 EDT
%changelog
* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.8-2
- Disable GTK support completely as we already ship tonnes of GUI mixer apps,
  and aumix is present only for initscripts and as a console mixer, and
  the new 2.8 default of running GTK when in X is running is a very confusing
  change of operation to users (#91362,91783)
- Disable xaumix as it doesn't work anyway, and doesn't make sense without
  also including GTK support

Note You need to log in before you can comment on or make changes to this bug.