Bug 919311 - running /etc/cron.daily/0logwatch spins up drive
running /etc/cron.daily/0logwatch spins up drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 454582
  Show dependency treegraph
 
Reported: 2013-03-07 22:09 EST by Peter Backes
Modified: 2013-06-25 03:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 03:15:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Backes 2013-03-07 22:09:41 EST
Description of problem:
since about a week or two, the automatic (or a manual) run of /etc/cron.daily/0logwatch spins up disks that have no mounted partitions and that have been put to sleep with hdparm -y

Version-Release number of selected component (if applicable):
logwatch-7.4.0-23.20130102svn127.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1. add disk
2. put disk to sleep with eg hdparm -y /dev/sdb
3. run /etc/cron.daily/0logwatch
  
Actual results:
disk spins up

Expected results:
disk status unaffected
Comment 1 Peter Backes 2013-03-09 01:07:25 EST
apparently caused by mdadm --examine --scan being invoked in /usr/share/logwatch/scripts/services/mdadm
Comment 2 Peter Backes 2013-03-09 01:18:29 EST
Workaround: yum downgrade logwatch

It currently downgrades to 7.4.0-18.20120619svn110.fc18.noarch which has no /usr/share/logwatch/scripts/services/mdadm
Comment 4 Peter Backes 2013-06-21 15:17:46 EDT
Better workaround: Append the following line to /etc/logwatch/conf/logwatch.conf

Service = "-mdadm"
Comment 5 Jan Synacek 2013-06-25 03:15:25 EDT
(In reply to Peter Backes from comment #4)
> Better workaround: Append the following line to
> /etc/logwatch/conf/logwatch.conf
> 
> Service = "-mdadm"

Not a workaround, it's just a matter of configuration. Closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.