Bug 91943 - Postgresql init script system boot failure
Postgresql init script system boot failure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Fernando Nasser
David Lawrence
:
: 97605 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 00:56 EDT by Cristian Gafton
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 07:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Gafton 2003-05-30 00:56:18 EDT
The postgresql init script is trying to figure out how it is called as and
therefore at the startup does somethin like:
NAME=`basename $0`

Based on that $NAME then it tries to read the /etc/sysconfig/pgsql/$NAME
configuration file, if it exists.

There are 2 problems that keep this from working right:
- first, during the system bootup time, the script is called as S85postgresql,
which means that $NAME is assigned 'S85postgresql' instead of the desired
'postgresql'. This works correctly when doing a "system postgresql restart", but
fails to read the postgresql config file during the first boot.

- secoindly, in the config file one could define the PGOPTS variable with
additional options to be passed to the postgres engine by the postmaster daemon.
While that variable is exported from the init script, it is used nowhere in the
start() function, therefore rendering it useless.
Comment 1 Andrew Overholt 2003-05-30 14:34:05 EDT
The init script is currently in the process of being overhauled.  I've never
really seen the point of the basename ilne anyways, but that is an easy fix. 
Usage of PGOPTS can be integrated with the coming enhancements.  Re-assigning to
fnasser who is working on the init script.
Comment 2 Andrew Overholt 2003-06-18 07:53:54 EDT
These two issues are fixed in RAWHIDE.
Comment 3 Andrew Overholt 2003-06-18 07:54:38 EDT
*** Bug 97605 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.