Bug 91945 - Spamassassin does not work
Spamassassin does not work
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-05-30 04:07 EDT by Nicolas Mailhot
Modified: 2007-03-27 00:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 14:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2003-05-30 04:07:47 EDT
Description of problem:
spamassassin -k fails with compilation error

Version-Release number of selected component (if applicable):
spamassassin-2.53-12

How reproducible:
Always

Steps to Reproduce:
[nim@ulysse nim]$ spamassassin -k < message.txt
    
Actual results:
Can't locate loadable object for module HTML::Parser in @INC (@INC contains:
/usr/src/build/251404-i386/install//usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/HTML.pm line 7
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/HTML.pm line 7.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/HTML.pm line 7.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/PerMsgStatus.pm line 44.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/PerMsgStatus.pm line 44.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin.pm line 62.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin.pm line 62.
Compilation failed in require at /usr/bin/spamassassin line 69.


Expected results:
Unknown (first time I play with spamassassin). But not this:)

Additional info:
System is up-to-date Rawhide (updated from RH 8.0)
Comment 1 Nicolas Mailhot 2003-05-30 04:13:38 EDT
Change this to bad permissions - it works as root

(fails for normal user both with nfs-mounted home and local home)
Comment 2 Nicolas Mailhot 2003-05-30 04:55:32 EDT
Change this to "I don't know what the hell is going on"

It works perfectly on a clean RH 9 updated to Rawhide (week-old install)
It doesn't at all on this post.
Perl packages are the same (rpm -qa | grep perl | sort + diff)
Comment 3 Nicolas Mailhot 2003-05-30 05:24:01 EDT
And it works after rpm -e ing all perl packages, removing the leftover dirs and
reinstalling them from rawhide repository

So one rpm upgrade at some time barfed perl install enough to confuse
spamassassin:(.
Comment 4 Alexander Farley 2003-06-02 12:00:53 EDT
I was having a problem similar to this. The problem might be with perl-5.8.1
(rather than 5.8.0 which is in RH 9) in that spamassassin for whatever reason
can not find perl modules even when they exist. I found that recompiling/
replackaging (using the non-redhat cpan2rpm tool) the needed perl modules to be
inserted into the appropriate 5.8.1 directories rather the 5.8.0 directories
resolved the situation. Though, if you are still using perl-5.8.0 then ignore my
comment.
Comment 5 Nicolas Mailhot 2003-06-02 13:10:03 EDT
Well, rawhide it at perl-5.8.0-89.pre19525.1 now.

What kills me is removing perl packages and reinstalling them fixed it -
obviously one of them had at some time a borked upgrade script
Comment 6 Warren Togami 2003-06-03 04:43:56 EDT
IIRC, many packages that use perl will only work with the same %{version} of
perl as the RPM was built against because the directory name changes with
%{version}.  Were the perl and spamassassin binary RPMS in a distro not
consistent with each other?
Comment 7 Nicolas Mailhot 2003-06-03 04:56:20 EDT
I do full rawhide apt syncs on my workstation.
So yes, the perl packages must have been fully in sync.

I did a mv /usr/lib/perl backup, rpm -Uvh --force of all the rpm -qa | grep
perl, then a diff -uNr backup /usr/lib/perl to find what perl packages I had missed.

I then did a rpm -Uvh --force of the missing ones.

The *only* old leftover was some alien perl files (existed at some time, non
longuer in RH), and I did a rpm -e alien to fix it.
Comment 8 Chip Turner 2003-06-04 09:58:34 EDT
spamassassin and perl should now be sync'd; nothing in rawhide should mention
5.8.1 anywhere, it should all be 5.8.0.  are there any cases where this isn't true?
Comment 9 Nicolas Mailhot 2003-06-04 13:37:35 EDT
The only non-current perl rpms I had on this system were alien (stuck at 5.6x).
Why it should confuse spamassassin is beyond me.

This system was originally redhat-8.0 (or 7.3, I don't remember too well) based
then continuously upgraded following rawhide changes

Spamassassin is the first perl program on this system that displayed such a
strange failure
Comment 10 Chip Turner 2003-07-14 09:29:29 EDT
can you reproduce it on a less-crufty installation?  sending the output of
'strace -f -o strace.log spamassassin -k' can help
Comment 11 Nicolas Mailhot 2003-07-14 11:01:16 EDT
I'm afraid now that I've cleaned up perl packages on this computer I can not
reproduce it at all, wether on crufty installation or not:(

Guess I was a bit too hasty to get by system back in useable shape
Comment 12 Warren Togami 2003-09-21 06:59:02 EDT
May I recommend closing as WORKSFORME.
Comment 13 Nicolas Mailhot 2003-09-21 17:37:46 EDT
I agree, this is a real bug but I do not see how we can reproduce it anytime soon :(
Comment 14 Jeremy Portzer 2003-10-22 10:13:05 EDT
SpamAssassin is now at 2.60 and WORKSFORME as well (Fedora Core test3)
Recommend this be closed as it was likely a byproduct of the reporter's mixed up
Perl installation, and not a SpamAssassin bug.
Comment 15 Chris Ricker 2003-10-22 14:35:44 EDT
<aol>works here too </aol>

closing out -- please reopen if reproduce

Note You need to log in before you can comment on or make changes to this bug.