Bug 91953 - "apmscript start" should call apmcontinue-pre and adjust power settings.
Summary: "apmscript start" should call apmcontinue-pre and adjust power settings.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apmd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-05-30 09:51 UTC by Aleksey Nogin
Modified: 2014-03-17 02:36 UTC (History)
2 users (show)

Fixed In Version: 3.0.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 22:05:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2003-05-30 09:51:07 UTC
Currently "apmscript start" only calls "apmcontinue start" and fails to do
anything else. It should:
- Call "apmcontinue-pre start" before doing anything else.
- Check whether we are using A/C or battery power and adjust the settings
(cpufreq, laptop mode, etc) accordingly.

P.S. Is there a reason why each case in the ``case "$PROG" in'' switch has its
own calls to apmcontinue-pre/apmcontinue? Would not it be better to just call
apmcontinue-pre before the ``case'' and call apmcontinue after the esac?

Comment 1 Alexandre Oliva 2003-09-23 19:55:11 UTC
Still a problem with apmd-3.0.2-19


Comment 2 Bill Waddington 2004-11-11 18:39:55 UTC
This doesn't seem to have changed in FC2 or 3. I'm a noob, but I think
I have fixed it and a few other things. Since I'm a rookie, I won't
try to post patches here, but if anyone wants to give it a try:
http://www.beezmo.com/ThinkPadR40.htm see the "CPU Frequency scaling
(speedstep) and Laptop Mode" section of the Fedora Core 2 page.

Bill

Comment 3 Bill Nottingham 2005-03-16 22:05:39 UTC
This was fixed in -20.


Note You need to log in before you can comment on or make changes to this bug.