Bug 92038 - anaconda-ks.cfg invalid if LVM used on top of RAID
anaconda-ks.cfg invalid if LVM used on top of RAID
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 09:29 EDT by Phil Davis
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:39:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Davis 2003-06-01 09:29:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Set up Software RAID and then LVM on 1 server interactively and then used
modified anaconda-ks.cfg file to setup 2nd identical server.

Only modifications to ks file were to uncomment partition lines and to change
name and IP address for second server.

anaconda did a traceback when tried to set up partition for RAID.

Traced problem to the line in the ks.cfg file that said:

raid pv.12 --fstype physical volume (LVM) --level=RAID1 raid.6 raid.8

The fstype has spaces in it which confuse the parser.

Changed file so line was:

raid pv.12 --fstype lvm --level=RAID1 raid.6 raid.8

and 2nd kickstart install worked fine.

Modified anaconda-ks.cfg file was:

---------------------------------------------------------------------
# Kickstart file automatically generated by anaconda.

install
lang en_US.UTF-8
langsupport --default en_GB.UTF-8 en_GB.UTF-8 en_US.UTF-8
keyboard uk
mouse genericwheelps/2 --device psaux
skipx
network --device eth0 --bootproto static --ip 192.168.002.3 --netmask
255.255.255.0 --gateway 192.168.2.252 --nameserver 192.168.2.252 --hostname lea
network --device eth1 --bootproto static --ip 192.168.10.3 --netmask
255.255.255.0 --gateway 192.168.2.252 --nameserver 192.168.2.252 --hostname lea
rootpw --iscrypted XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
firewall --disabled
authconfig --enableshadow --enablemd5
timezone --utc Europe/London
bootloader --location=partition
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all
part raid.3 --size=100 --ondisk=hde --asprimary
part raid.7 --size=100 --ondisk=hdg --asprimary
part swap --size=4096 --ondisk=hdg
part swap --size=4096 --ondisk=hde
part raid.8 --size=100 --grow --ondisk=hdg
part raid.6 --size=100 --grow --ondisk=hde
raid /boot --fstype ext3 --level=RAID1 raid.3 raid.7
raid pv.12 --fstype physical volume (LVM) --level=RAID1 raid.6 raid.8
volgroup Volume00 pv.12
logvol /data --fstype ext3 --name=data --vgname=Volume00 --size=8192
logvol / --fstype ext3 --name=root --vgname=Volume00 --size=4096
logvol /var --fstype ext3 --name=var --vgname=Volume00 --size=500

%packages
@ Administration Tools
@ Authoring and Publishing
@ British Support
@ DNS Name Server
@ Development Tools
@ Dialup Networking Support
@ Editors
@ FTP Server
@ Graphical Internet
@ Graphics
@ Kernel Development
@ Mail Server
@ Network Servers
@ Printing Support
@ SQL Database Server
@ Server Configuration Tools
@ System Tools
@ Text-based Internet
@ Web Server
@ Windows File Server
@ X Window System

%post
-------------------------------------------------------------------




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Find machine with 2 identical disks on hde and hdg
2. do kickstart install using modified cfg file
   
I used "linux text ks=http://192.168.2.1/name-ks.cfg" but same happens without
using text.


Actual Results:  anconda traceback.Sorry do not have exact error msg but
something about invalid  parition

Expected Results:  Install should have completed ok

Additional info:

Servers had on-board promise IDE controller hence disks appearing as hde and hdg.
Comment 1 Michael Fulbright 2003-06-12 12:57:34 EDT
Maybe related to bug 73884.
Comment 2 Jeremy Katz 2005-09-21 16:39:02 EDT
This should be better in current releases

Note You need to log in before you can comment on or make changes to this bug.