Bug 920749 - thg doesn't work in PyQt-4.10
thg doesn't work in PyQt-4.10
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tortoisehg (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mads Kiilerich
Fedora Extras Quality Assurance
: Patch
: 920765 (view as bug list)
Depends On:
Blocks: kde-4.10
  Show dependency treegraph
 
Reported: 2013-03-12 12:23 EDT by Rex Dieter
Modified: 2013-03-22 17:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 17:15:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-03-12 12:23:54 EDT
See also upstream issue:
https://bitbucket.org/tortoisehg/thg/issue/2467/
Comment 1 Rex Dieter 2013-03-12 12:25:07 EDT
(and fyi, we're upgrading to PyQt-4.10 across fedora 17/18 , in updates-testing now)
Comment 2 Rex Dieter 2013-03-12 12:27:11 EDT
Link to upstream commit/fix:
https://bitbucket.org/tortoisehg/thg/commits/e571f9b3eadc
Comment 3 Mads Kiilerich 2013-03-12 13:13:49 EDT
*** Bug 920765 has been marked as a duplicate of this bug. ***
Comment 4 Neal Becker 2013-03-12 13:50:13 EDT
Need to patch qtlib.py, dunno if that was in the above commits
Comment 5 Mads Kiilerich 2013-03-12 14:02:40 EDT
(In reply to comment #4)
> dunno if that was in the above commits

It shouldn't be hard to find out.
Comment 6 Fedora Update System 2013-03-12 21:25:14 EDT
tortoisehg-2.4.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tortoisehg-2.4.3-2.fc17
Comment 7 Fedora Update System 2013-03-12 21:25:25 EDT
tortoisehg-2.6.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tortoisehg-2.6.2-2.fc18
Comment 8 Fedora Update System 2013-03-13 23:04:48 EDT
Package tortoisehg-2.6.2-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tortoisehg-2.6.2-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3839/tortoisehg-2.6.2-2.fc18
then log in and leave karma (feedback).
Comment 9 Kevin Kofler 2013-03-21 18:36:27 EDT
Ping? Can you please push the 2 testing updates to stable now?
Comment 10 Fedora Update System 2013-03-22 17:15:54 EDT
tortoisehg-2.6.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-03-22 17:18:00 EDT
tortoisehg-2.4.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.