Bug 92081 - rpc.mountd: getfh failed: Operation not permitted - 'soft' mount information not being cleared
rpc.mountd: getfh failed: Operation not permitted - 'soft' mount information ...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-02 11:53 EDT by R P Herrold
Modified: 2007-04-18 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 11:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
some lines of /var/log/messages (557 bytes, text/plain)
2004-04-01 10:56 EST, Alejandro Bonet
no flags Details

  None (edit)
Description R P Herrold 2003-06-02 11:53:07 EDT
This looks like bugzilla 50101 and 61152 again -- but with RHL 7.3 and nfs-utils
0.3.3-5

The client locked up hard for reasons unrelated to NFS, and had to be
power-cycled.  I had not yet cycled the nfs server through a restart.

From the client:

[root@server3 root]# mount /root/master
mount: server4.brook.tel:/root/master failed, reason given by server: Permission
denied
[root@server3 root]# umount /root/master
umount: /root/master: not mounted
[root@server3 root]# mount /root/master
mount: server4.brook.tel:/root/master failed, reason given by server: Permission
denied
[root@server3 root]# mount /root/master
mount: server4.brook.tel:/root/master failed, reason given by server: Permission
denied
[root@server3 root]# rpm -qa | grep nfs
nfs-utils-0.3.3-5
[root@server3 root]# cat /etc/fstab
<snip>


#       for passwd syncing
server4.brook.tel:/root/master   /root/master   nfs
ro,noexec,noatime,nosuid,rsize=8192,soft,nolock,soft 0 0
#       for common users
server4.brook.tel:/home   /home   nfs
rw,nosuid,noatime,rsize=8192,soft,nolock,soft 0 0
#

=============================================================================

and at the server:


[root@www root]# rpm -qa | grep nfs
nfs-utils-0.3.3-5
[root@www root]# cat /var/log/messages | grep rpc | tail
Jun  2 11:03:18 www rpc.mountd: authenticated mount request from
ws190.brook.lan:689 for /opt/ltsp/i386 (/opt/ltsp/i386)
Jun  2 11:12:14 www rpc.mountd: authenticated mount request from
ws139.brook.lan:689 for /opt/ltsp/i386 (/opt/ltsp/i386)
Jun  2 11:20:28 www rpc.mountd: authenticated mount request from
ws224.brook.lan:689 for /opt/ltsp/i386 (/opt/ltsp/i386)
Jun  2 11:34:48 www rpc.mountd: authenticated unmount request from
dhcp-10-30-0-253.brook.tel:832 for /root/master (/root/master)
Jun  2 11:34:50 www rpc.mountd: authenticated mount request from
server3.brook.tel:834 for /root/master (/root/master)
Jun  2 11:34:50 www rpc.mountd: getfh failed: Operation not permitted
Jun  2 11:36:07 www rpc.mountd: authenticated mount request from
dhcp-10-30-0-253.brook.tel:855 for /root/master (/root/master)
Jun  2 11:36:07 www rpc.mountd: getfh failed: Operation not permitted
Jun  2 11:36:16 www rpc.mountd: authenticated mount request from
dhcp-10-30-0-253.brook.tel:861 for /root/master (/root/master)
Jun  2 11:36:16 www rpc.mountd: getfh failed: Operation not permitted
[root@www root]# cat /etc/exports

###   ## L TS-begin ##
#
# The lines between the 'LTS-begin' and the 'LTS-end' were added
# on: Wed Nov 28 11:19:42 PST 2001 by the ltsp installation script.
# For more information, visit the ltsp homepage
# at http://www.ltsp.org
#

/opt/ltsp/i386                  192.168.0.0/255.255.255.224(ro,no_root_squash)
/var/opt/ltsp/swapfiles         192.168.0.0/255.255.255.224(rw,no_root_squash)
#
/opt/ltsp/i386                  192.168.0.32/255.255.255.224(ro,no_root_squash)
/var/opt/ltsp/swapfiles         192.168.0.32/255.255.255.224(rw,no_root_squash)
#
/opt/ltsp/i386                  192.168.0.64/255.255.255.224(ro,no_root_squash)
/var/opt/ltsp/swapfiles         192.168.0.64/255.255.255.224(rw,no_root_squash)
#
/opt/ltsp/i386                  192.168.0.96/255.255.255.224(ro,no_root_squash)
/var/opt/ltsp/swapfiles         192.168.0.96/255.255.255.224(rw,no_root_squash)
#
/opt/ltsp/i386                  192.168.0.128/255.255.255.128(ro,no_root_squash)
/var/opt/ltsp/swapfiles         192.168.0.128/255.255.255.128(rw,no_root_squash)
#
#
/opt/ltsp/i386                  10.30.0.0/255.255.255.0(ro,no_root_squash)
/var/opt/ltsp/swapfiles         10.30.0.0/255.255.255.0(rw,no_root_squash)

#
# The following entries need to be uncommented if you want
# Local App support in ltsp
#
/home                  192.168.0.0/255.255.0.0(rw,no_root_squash)
/home                  10.30.0.0/255.255.0.0(rw,no_root_squash)

###   ## L TS-end ##

/root/master            192.168.0.0/255.255.0.0(ro,no_root_squash)
/root/master            10.30.0.0/255.255.0.0(ro,no_root_squash)

[root@www root]#

======================================

interior DNS is fully functional.

The presence of the soft for some and norootsquash is a not often tested path.

------------------

WORKAROUND: restarting the server side nfsd cleared things up ... but with the
'soft' option, this should not have been needed.

------------------

Ask if additional information is needed
Comment 1 Hans Deragon 2004-01-19 10:00:51 EST
I experience the same problem on RHL 9 with the latest RPMs installed
(nfs-utils-1.0.1-3.9 on the server).  Some clients can connect, but
others suddenly cannot.  I simply have to run "exportfs -r" on the
server and everybody can remount again.  However, I need to run
"exportfs -r" every so often because the problem is recurring (I am
considering running "exportfs -r" in a cronjob).  Unfortunatly, I
cannot reproduce the problem at will as I have not figured out what
causes NFS to suddenly refuse connections from 

This is a serious problem.  Linux cannot be considered Enterprise
ready with such intermittent failure of such a popular service as NFS
is.  To help with the investigation, I suggest that more debuging
information should be spit out.  "rpc.mountd: getfh failed: Operation
not permitted" does not give much to work with.  What operation is not
permitted?  If a new RPM with more debugging information for RHL 9 is
made available, I would be more than happy to install it and report
the problems when they occur.
Comment 2 jdavis 2004-02-05 00:20:12 EST
i'm seeing similar problems with rhel ws3 clients to both
rhes 2.1 servers and redhat linux servers

all rhes 2.1 and rhel ws 3 servers are up to date with redhat
network as far as patches/updates

problems could be related to improper shutdowns of clients

exportfs -r seems to help problem


Feb  4 15:30:19 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:19 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:20 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:26 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:26 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:26 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:28 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:28 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:29 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:29 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 15:30:29 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:09 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:09 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:17 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:17 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:21 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:21 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:23 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:23 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:24 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:24 hacscs001 rpc.mountd: getfh failed: Operation not 
permitted





Feb  4 16:52:18 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:18 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:20 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:20 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:21 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:21 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:16 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:16 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:36 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:47 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:47 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:21 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:21 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:26 hacscs002 rpc.mountd: getfh failed: Operation not 
permitted



Feb  4 16:52:20 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:20 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:21 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:52:21 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:16 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:16 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 16:53:36 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:44 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:46 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:47 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:10:52 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:05 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:06 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:14 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 17:17:21 hacscs003 rpc.mountd: getfh failed: Operation not 
permitted





old redhat nfs server

Feb  4 14:31:52 wolf126 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 14:34:44 wolf126 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 14:35:59 wolf126 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 14:39:57 wolf126 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 14:47:37 wolf126 rpc.mountd: getfh failed: Operation not 
permitted
Feb  4 14:50:38 wolf126 rpc.mountd: getfh failed: Operation not 
permitted


thanks....jeff davis
 
Comment 3 Toshio Kuratomi 2004-02-29 12:09:31 EST
Server & client packages:
[nfs-utils    1.0.6-1]
[kernel       2.4.22-1.2174.nptl-custom]
[lvm          1.0.3-13]
[portmap      4.0-57]
[OS           Fedora Core 1]
 
I am experiencing this bug on FC1 as well.  Here's some new things
that I observe:
 
After an unexpected client failure (power fail) the server is unable
to serve one of it's exported filesystems.  This happens to be the
only filesystem I am exporting that is a toplevel lvm partition.
 
Server /etc/fstab:
/dev/system/nettmp      /media/net      reiserfs        defaults     
  1 1
 
Server /etc/exports:
/media/net 192.168.3.0/24(rw,sync,no_root_squash) # Network temp dir
/media/net/fedora 192.168.3.0/24(rw,no_root_squash,sync) # Fedora Packages
 
After the power fail, I can mount both nfs shares on the server.
I can mount 192.168.3.1:/media/net/fedora but not /media/net on the
client.
 
No variation of /etc/exports (Taking out no_root_squash, using an
explicit IP address, using wildcards) seems to allow the client to
connect.
 
Rebooting client and server, restarting nfs, etc does not help.
 
Stopping nfs, manually removing /var/lib/nfs/*tab, and restarting
worked.  I will try exportfs -r next time it happens.
 
Server /var/log/messages:
Feb 29 08:49:40 Springer rpc.mountd: authenticated mount request from
Madison.badger.com:918 for /media/net/fedora (/media/net/fedora)
[...]
Feb 29 08:51:27 Springer rpc.mountd: authenticated mount request from
Madison.badger.com:988 for /media/net (/media/net)
Feb 29 08:51:27 Springer rpc.mountd: getfh failed: Operation not permitted

===
Note: I think this bug was also reported as bug #61152 and supposedly
fixed in Rawhide at the time.  However, it was reported to still
occur, despite it's closed nature.
Comment 4 Alejandro Bonet 2004-04-01 10:56:39 EST
Created attachment 99041 [details]
some lines of /var/log/messages

I have the same problem: rpc.mountd: getfh failed: Operation not permitted

My case is the following:

I have two external USB 2.0 hard drives correctly mounted in /dusb/disco1 and
/dusb/disco2 . Their respective contents are well accessed.

I try to export /dusb (which has no more directories in addition of disco1 and
disco2) including the line

/dusb 10.0.0.0/255.255.255.0(rw,sync)

in /etc/exports

This server has IP 10.0.0.201

When i try to mount 10.0.0.201:/dusb on any clien of my network i cant.
I receive (in the client side) a Permission denied error, and the
/var/log/message receive a new line:

rpc.mountd: getfh failed: Operation not permitted

BUT: If i export the /dusb/disco1 and /dusb/disco2 separately (running exportfs
-ra to update service) and i try to mount both separately (in any client
machine) it works perfectly.

There is any kind of limit about nfs mount over a "multimounted" directory?
In other words... Is nfs-mount "no-recursive", or "no-nested"?

I can't imagine whats the problem if not.

Regards.

Alejandro Bonet
alex@winbabel.org
Comment 5 R P Herrold 2005-02-23 11:42:15 EST
more than six months old - long since overtaken by events - closing; please
reopen if appropriate
Comment 6 jehan procaccia 2005-05-19 05:56:21 EDT
I am facing the problem again :-( 

My NFS server:
$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 3 (Taroon Update 4)
$ uname -a
Linux cobra3.int-evry.fr 2.4.21-27.0.4.ELsmp #1 SMP Sat Apr 16 18:43:06 EDT 2005
i686 i686 i386 GNU/Linux
My NFS client in an Fedora Core release 2 with kernel 2.6.10-1.770_FC2
it does:
$ mount cobra3:/p2v5f2/inf/domy /mnt/nfs
mount: cobra3:/p2v5f2/inf/domy failed, reason given by server: Permission denied

server respond
May 19 11:48:39 cobra3 rpc.mountd: authenticated mount request from
mamba.int-evry.fr:725 for /p2v5f2/inf/domy (/p2v5f2)
May 19 11:48:39 cobra3 rpc.mountd: getfh failed: Operation not permitted

However if want to mount an other filesystem it work !
$ mount cobra3:/p2v5f1/mci/test /mnt/nfs

server logs:
May 19 11:50:58 cobra3 rpc.mountd: authenticated mount request from
mamba.int-evry.fr:795 for /p2v5f1/mci/test (/p2v5f1)
May 19 11:50:58 cobra3 rpc.mountd: authenticated mount request from
mamba.int-evry.fr:804 for /p2v5f2/inf/cobra3: (/p2v5f2)

Workaround -> restart nfs services, but I don't like that !
I reopen the bug report ...

Comment 7 Steve Dickson 2005-05-19 07:23:44 EDT
Try exporting the filesystem with the no_subtree_check option

Note You need to log in before you can comment on or make changes to this bug.