Bug 920960 - mate-settings-daemon: on_screen_size_changed(): mate-settings-daemon killed by SIGSEGV
Summary: mate-settings-daemon: on_screen_size_changed(): mate-settings-daemon killed b...
Keywords:
Status: CLOSED DUPLICATE of bug 1102581
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-settings-daemon
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:947a161ab1a4f616eb609b7e9ec...
: 924091 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-13 07:47 UTC by Mike Zet
Modified: 2015-01-08 20:54 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-08 20:54:31 UTC


Attachments (Terms of Use)
File: backtrace (29.25 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: cgroup (131 bytes, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: core_backtrace (1.75 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: dso_list (12.68 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: environ (1.38 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: maps (59.77 KB, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: open_fds (782 bytes, text/plain)
2013-03-13 07:47 UTC, Mike Zet
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-03-13 07:48 UTC, Mike Zet
no flags Details
File: var_log_messages (248 bytes, text/plain)
2013-03-13 07:48 UTC, Mike Zet
no flags Details

Description Mike Zet 2013-03-13 07:47:37 UTC
Version-Release number of selected component:
mate-settings-daemon-1.5.5-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/mate-settings-daemon
crash_function: on_screen_size_changed
executable:     /usr/libexec/mate-settings-daemon
kernel:         3.8.2-206.fc18.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 on_screen_size_changed at msd-background-manager.c:267
 #1 _g_closure_invoke_va at gclosure.c:840
 #3 g_signal_emit_by_name at gsignal.c:3393
 #4 process_monitors_change at gdkscreen-x11.c:1163
 #5 _gdk_x11_screen_size_changed at gdkscreen-x11.c:1198
 #6 gdk_event_translate at gdkevents-x11.c:2152
 #7 _gdk_events_queue at gdkevents-x11.c:2336
 #13 gtk_main at gtkmain.c:1257

Comment 1 Mike Zet 2013-03-13 07:47:41 UTC
Created attachment 709378 [details]
File: backtrace

Comment 2 Mike Zet 2013-03-13 07:47:43 UTC
Created attachment 709379 [details]
File: cgroup

Comment 3 Mike Zet 2013-03-13 07:47:45 UTC
Created attachment 709380 [details]
File: core_backtrace

Comment 4 Mike Zet 2013-03-13 07:47:48 UTC
Created attachment 709381 [details]
File: dso_list

Comment 5 Mike Zet 2013-03-13 07:47:50 UTC
Created attachment 709382 [details]
File: environ

Comment 6 Mike Zet 2013-03-13 07:47:52 UTC
Created attachment 709383 [details]
File: limits

Comment 7 Mike Zet 2013-03-13 07:47:55 UTC
Created attachment 709384 [details]
File: maps

Comment 8 Mike Zet 2013-03-13 07:47:58 UTC
Created attachment 709386 [details]
File: open_fds

Comment 9 Mike Zet 2013-03-13 07:48:00 UTC
Created attachment 709387 [details]
File: proc_pid_status

Comment 10 Mike Zet 2013-03-13 07:48:02 UTC
Created attachment 709388 [details]
File: var_log_messages

Comment 11 Arthur Enright 2013-03-13 17:52:52 UTC
Laptop keeps rebooting at odd intervals, not sure what is going on.

backtrace_rating: 4
Package: mate-settings-daemon-1.5.5-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 12 Arthur Enright 2013-03-13 20:34:21 UTC
Turning off the laptop display (leaving only the external monitor)

backtrace_rating: 4
Package: mate-settings-daemon-1.5.5-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 13 Mike Zet 2013-03-14 15:15:08 UTC
Run Diablo II by wine and changing resolution to 800x600 crush desktop (reset MATE theme).

backtrace_rating: 4
Package: mate-settings-daemon-1.5.5-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 14 Dan Mashal 2013-03-14 15:21:51 UTC
Have you run a yum update lately?

Comment 15 Fedora Update System 2013-03-14 16:10:37 UTC
mate-file-manager-1.5.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-file-manager-1.5.5-1.fc17

Comment 16 Fedora Update System 2013-03-14 16:10:54 UTC
mate-file-manager-1.5.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-file-manager-1.5.5-1.fc18

Comment 17 Fedora Update System 2013-03-16 01:24:04 UTC
Package mate-file-manager-1.5.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.5.5-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3903/mate-file-manager-1.5.5-1.fc17
then log in and leave karma (feedback).

Comment 18 Harry Diggens 2013-03-18 11:41:37 UTC
login in , dual screen

backtrace_rating: 4
Package: mate-settings-daemon-1.5.5-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 19 Sam Tygier 2013-03-19 12:07:45 UTC
get the when hot plugging an external vga monitor to my thinkpad x230. Happens every time, but has worked fine in the recent past. The external monitor does get activated, but it is not remembering the previous layout.

backtrace_rating: 4
Package: mate-settings-daemon-1.5.5-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 20 Sam Tygier 2013-03-19 12:09:35 UTC
I installed mate-file-manager-1.5.5-1.fc18 as suggested by abrt, but I still get the crash.

Comment 21 Harry Diggens 2013-03-19 12:20:15 UTC
Move monitor to left and laptop screen right, clicked apply.

backtrace_rating: 4
cmdline:        /usr/libexec/mate-settings-daemon
crash_function: on_screen_size_changed
executable:     /usr/libexec/mate-settings-daemon
kernel:         3.8.3-201.fc18.x86_64
package:        mate-settings-daemon-1.5.5-1.fc18
reason:         Process /usr/libexec/mate-settings-daemon was killed by signal 11 (SIGSEGV)
uid:            1000

Comment 22 Harry Diggens 2013-03-21 20:47:37 UTC
Unplugged monitor and plugged back in

backtrace_rating: 4
cmdline:        /usr/libexec/mate-settings-daemon
crash_function: on_screen_size_changed
executable:     /usr/libexec/mate-settings-daemon
kernel:         3.8.3-203.fc18.x86_64
package:        mate-settings-daemon-1.5.5-1.fc18
reason:         Process /usr/libexec/mate-settings-daemon was killed by signal 11 (SIGSEGV)
uid:            1000

Comment 23 Dan Mashal 2013-03-26 09:21:32 UTC
*** Bug 924091 has been marked as a duplicate of this bug. ***

Comment 24 Pasi Karkkainen 2013-03-26 16:47:38 UTC
I'm having the same problem with mate-settings-daemon 1.5.5-1.fc18. It crashes with sigsegv whenever I try to adjust display settings (enable/disable external monitor) on my laptop.

Comment 25 Dan Mashal 2013-03-28 00:46:42 UTC
Please try with the latest packages in updates-testing and let me know if this issue still exists.

Comment 26 Thomas Waldecker 2013-03-28 13:06:47 UTC
It works for me. I can activate the external monitor.
But mate-control-center got a SIGSEGV after setting the monitors, bug is already reported: https://bugzilla.redhat.com/show_bug.cgi?id=879663

thomas ~% rpm -qa mate-settings-daemon
mate-settings-daemon-1.5.7-1.fc18.i686
thomas ~% uname -a                                                         
Linux localhost.localdomain 3.8.4-202.fc18.i686 #1 SMP Thu Mar 21 17:23:45 UTC 2013 i686 i686 i386 GNU/Linux

Comment 27 Harry Diggens 2013-03-28 21:33:08 UTC
Looks better.
Keep you posted

Comment 28 Fedora Update System 2013-03-29 01:29:02 UTC
mate-file-manager-1.5.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2013-03-29 01:39:10 UTC
mate-file-manager-1.5.5-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Sam Tygier 2014-01-15 13:51:32 UTC
Just had this in mate-settings-daemon-1.6.2-1.fc20
https://retrace.fedoraproject.org/faf/reports/75452/

Comment 31 Sam Tygier 2014-01-21 11:40:30 UTC
and again with mate-settings-daemon-1.6.2-2.fc20

Comment 32 Sam Tygier 2014-02-03 10:38:04 UTC
I am still seeing this (or at least ABRT points me to this bug). Please can it be reopened?

Comment 33 Grzesiek 2014-10-21 10:01:41 UTC
it's still existing at mate-settings-daemon-1.8.2-1.fc20
https://retrace.fedoraproject.org/faf/reports/10588/

Comment 34 Wolfgang Ulbrich 2015-01-08 20:51:35 UTC
a new build comming soon, see https://github.com/mate-desktop/mate-settings-daemon/issues/67

Comment 35 Wolfgang Ulbrich 2015-01-08 20:54:31 UTC

*** This bug has been marked as a duplicate of bug 1102581 ***


Note You need to log in before you can comment on or make changes to this bug.