Bug 879663 - [abrt] mate-control-center-1.5.0-2.fc18: Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
Summary: [abrt] mate-control-center-1.5.0-2.fc18: Process /usr/bin/mate-display-proper...
Keywords:
Status: CLOSED DUPLICATE of bug 1062796
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-control-center
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3a814a937c52256fd2f2841013f...
: 928121 966925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-23 15:40 UTC by leigh scott
Modified: 2014-11-14 15:32 UTC (History)
37 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-12 15:40:11 UTC
Type: ---


Attachments (Terms of Use)
File: core_backtrace (1.05 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: environ (1.56 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: backtrace (20.41 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: cgroup (128 bytes, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: executable (32 bytes, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: maps (47.81 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: dso_list (9.90 KB, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: proc_pid_status (920 bytes, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: var_log_messages (504 bytes, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: open_fds (428 bytes, text/plain)
2012-11-23 15:40 UTC, leigh scott
no flags Details
File: backtrace (129.72 KB, text/plain)
2013-08-20 19:29 UTC, Leonid Kanter
no flags Details

Description leigh scott 2012-11-23 15:40:19 UTC
Version-Release number of selected component:
mate-control-center-1.5.0-2.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 3
cmdline:        mate-display-properties
kernel:         3.6.6-9.fc18.x86_64

truncated backtrace:
:Thread no. 1 (6 frames)
: #0 ??
: #1 gdk_event_apply_filters at gdkevents-x11.c:356
: #2 gdk_event_translate at gdkevents-x11.c:1052
: #3 _gdk_events_queue at gdkevents-x11.c:2336
: #9 gtk_dialog_run at gtkdialog.c:1094
: #10 run_application at xrandr-capplet.c:2520

Comment 1 leigh scott 2012-11-23 15:40:23 UTC
Created attachment 650520 [details]
File: core_backtrace

Comment 2 leigh scott 2012-11-23 15:40:25 UTC
Created attachment 650521 [details]
File: environ

Comment 3 leigh scott 2012-11-23 15:40:27 UTC
Created attachment 650522 [details]
File: backtrace

Comment 4 leigh scott 2012-11-23 15:40:31 UTC
Created attachment 650523 [details]
File: limits

Comment 5 leigh scott 2012-11-23 15:40:33 UTC
Created attachment 650524 [details]
File: cgroup

Comment 6 leigh scott 2012-11-23 15:40:35 UTC
Created attachment 650525 [details]
File: executable

Comment 7 leigh scott 2012-11-23 15:40:38 UTC
Created attachment 650526 [details]
File: maps

Comment 8 leigh scott 2012-11-23 15:40:40 UTC
Created attachment 650527 [details]
File: dso_list

Comment 9 leigh scott 2012-11-23 15:40:43 UTC
Created attachment 650528 [details]
File: proc_pid_status

Comment 10 leigh scott 2012-11-23 15:40:45 UTC
Created attachment 650529 [details]
File: var_log_messages

Comment 11 leigh scott 2012-11-23 15:40:47 UTC
Created attachment 650530 [details]
File: open_fds

Comment 12 Fedora Update System 2012-11-27 05:35:55 UTC
mate-control-center-1.5.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-control-center-1.5.1-1.fc18

Comment 13 Fedora Update System 2012-11-27 09:49:32 UTC
Package mate-control-center-1.5.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-control-center-1.5.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19103/mate-control-center-1.5.1-1.fc18
then log in and leave karma (feedback).

Comment 14 leigh scott 2012-11-27 10:13:29 UTC
I no longer care if it's fixed or not

Comment 15 Fedora Update System 2012-12-05 07:16:07 UTC
mate-control-center-1.5.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Dan Mashal 2013-02-04 05:27:48 UTC
Got this when hooking up multiple monitors.

Comment 17 Endre "Hrebicek" Balint-Nagy 2013-02-15 16:10:16 UTC
How I got here see https://bugzilla.redhat.com/show_bug.cgi?id=902732#c26

The problem occured when I wanted to rotate left by 90 degree my monitor.

backtrace_rating: 3
cmdline:        mate-display-properties
executable:     /usr/bin/mate-display-properties
kernel:         3.7.4-pinky
package:        mate-control-center-1.5.3-3.fc18
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
uid:            303

Comment 18 Endre "Hrebicek" Balint-Nagy 2013-02-15 16:14:10 UTC
Oops, the kernel was 3.7.7-201.fc18.x86_64, the previous one was a custom kernel.
Maybe abrt ignored the second coredump.
Cheers
Endre/Ondra

Comment 19 Endre "Hrebicek" Balint-Nagy 2013-02-17 13:01:27 UTC
I inserted a Geforce 8400 card 16xPCIe card inyo my desktop, and rotated the (now left side) 19" 3/4 monitoe by 90 degree left. While configuring mate for this, the crash appened. (Fortunately the image left rotated, but will remain so after a reboot?)  

backtrace_rating: 3
cmdline:        mate-display-properties
executable:     /usr/bin/mate-display-properties
kernel:         3.7.7-201.fc18.x86_64
package:        mate-control-center-1.5.3-3.fc18
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
uid:            303

Comment 20 Fedora Update System 2013-02-23 07:17:37 UTC
mate-control-center-1.5.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-control-center-1.5.4-1.fc18

Comment 21 Fedora Update System 2013-02-23 07:17:50 UTC
mate-control-center-1.5.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-control-center-1.5.4-1.fc17

Comment 22 Fedora Update System 2013-02-24 08:45:27 UTC
Package mate-control-center-1.5.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-control-center-1.5.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2946/mate-control-center-1.5.4-1.fc18
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2013-03-04 22:30:23 UTC
mate-control-center-1.5.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2013-03-04 22:36:14 UTC
mate-control-center-1.5.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Pasi Karkkainen 2013-03-26 16:49:40 UTC
mate-control-center-1.5.4-1.fc18 doesn't fix the crash problems for me!

Comment 26 Pasi Karkkainen 2013-03-26 16:51:25 UTC
.. more specifically it's mate-display-properties that crashes with sigsegv. It seems mate-control-center-1.5.4-1.fc18 doesn't properly fix the issue.

Comment 27 Adam 2013-04-08 19:05:41 UTC
Still crashing for me with latest update: mate-control-center-1.5.5-2.fc18

Comment 28 Dominik 'Rathann' Mierzejewski 2013-04-24 16:58:04 UTC
Still crashing for me with mate-control-center-1.5.5-3.fc18, so reopening.
From the stack trace it looks like it crashes inside libgdk-x11-2, which would make it a gtk2 bug, but I'll let Dan do the reassignment if applicable.

Comment 29 Dan Mashal 2013-04-25 02:52:23 UTC
Looking into it.

Comment 30 Pasi Karkkainen 2013-05-05 12:42:13 UTC
mate-display-properties is still crashing a lot for me! Very often when I try to change the monitor configuration it just segfaults..

$ rpm -qa | grep -i mate-control
mate-control-center-1.5.5-3.fc18.x86_64

$ dmesg | tail -3
[  632.513791] mate-display-pr[2243]: segfault at 13741c0 ip 00000000013741c0 sp 00007fffd8ad3448 error 15
[  956.949559] traps: mate-display-pr[2448] general protection ip:31d2860286 sp:7fff7e4f6720 error:0 in libgdk-x11-2.0.so.0.2400.16[31d2800000+ba000]
[  979.520002] traps: mate-display-pr[2491] general protection ip:31d2860286 sp:7fffa496ba90 error:0 in libgdk-x11-2.0.so.0.2400.16[31d2800000+ba000]

$ uname -a
Linux localhost.localdomain 3.8.11-200.fc18.x86_64 #1 SMP Wed May 1 19:44:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Comment 31 rich 2013-05-08 12:47:31 UTC
I am also getting this consistently.  When I dock my laptop and start mate-display-properties, it correctly sets the externally attached monitor and then crashes.

Comment 32 Dan Mashal 2013-05-08 13:22:28 UTC
Upstream bug was filed look for a MATE 1.6 push here I'm the next week.

Comment 33 Dominik 'Rathann' Mierzejewski 2013-05-26 18:39:41 UTC
Note that it's still crashing on Fedora 19.

$ rpm -q mate-control-center gtk2
mate-control-center-1.6.0-1.fc19.x86_64
gtk2-2.24.18-1.fc19.x86_64

Comment 34 Dan Mashal 2013-05-27 19:34:18 UTC
This is a glib problem.

Issue filed upstream:
https://github.com/mate-desktop/mate-control-center/issues/48

Comment 35 Dan Mashal 2013-05-27 19:36:43 UTC
*** Bug 928121 has been marked as a duplicate of this bug. ***

Comment 36 Dan Mashal 2013-05-27 19:38:12 UTC
*** Bug 966925 has been marked as a duplicate of this bug. ***

Comment 37 Dominik 'Rathann' Mierzejewski 2013-05-31 12:18:17 UTC
Shouldn't you reassign this bug to gtk2 component, then?

Comment 38 Christian Schmitt 2013-07-09 07:43:18 UTC
Currently I have the same problem I have a Laptop with 2 monitors, but still nothing really happens. I assign the new values to my monitor and everything still works. So I think this is very trivial.

Comment 39 satellitgo 2013-07-17 02:02:16 UTC
reported in closed bug on bugzilla (automatic) Mate 1.6.1

Comment 40 Pasi Karkkainen 2013-07-18 21:17:55 UTC
The crash (mate-display-properties SIGSEGV) still happens on fc18 with:

$ rpm -q mate-control-center gtk2
mate-control-center-1.6.0-2.fc18.x86_64
gtk2-2.24.19-1.fc18.x86_64
gtk2-2.24.19-1.fc18.i686

Comment 41 Pasi Karkkainen 2013-07-18 21:19:47 UTC
dmesg has the following entries about the mate-display-properties crashes:


[  120.074314] mate-display-pr[2100]: segfault at e84fb0 ip 0000000000e84fb0 sp 00007fff099ab7d8 error 15

[  251.619595] mate-display-pr[2213]: segfault at 7 ip 00007f02a559f292 sp 00007fff394a6be0 error 4 in libgdk-x11-2.0.so.0.2400.19[7f02a553f000+ba000]

[  271.794108] traps: mate-display-pr[2272] general protection ip:7f9a1a416296 sp:7fffa8780d00 error:0 in libgdk-x11-2.0.so.0.2400.19[7f9a1a3b6000+ba000]

[  415.249262] mate-display-pr[2400]: segfault at 0 ip           (null) sp 00007fffb408f958 error 14 in mate-display-properties[400000+f000]

[  424.849890] mate-display-pr[2447]: segfault at 10353e0 ip 00000000010353e0 sp 00007ffff5b14028 error 15

Comment 43 Majid Azimi 2013-08-18 07:15:08 UTC
I changed my screenshot, then I restored it to previous resolution and it crashed

reporter:       libreport-2.1.6
backtrace_rating: 3
cmdline:        mate-display-properties
executable:     /usr/bin/mate-display-properties
kernel:         3.10.7-200.fc19.x86_64
package:        mate-control-center-1.6.1-2.fc19
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=ca35336edf17939a8c9870b1d9875167821171aa
runlevel:       N 5
uid:            1000

Comment 44 Leonid Kanter 2013-08-20 19:29:10 UTC
Tried to turn off monitor panel while external monitor was connected and control center was on laptop panel. It was unable to move itself to external display.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        mate-display-properties
crash_function: gdk_event_apply_filters
executable:     /usr/bin/mate-display-properties
kernel:         3.10.7-200.fc19.x86_64
package:        mate-control-center-1.6.1-2.fc19
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 45 Leonid Kanter 2013-08-20 19:29:20 UTC
Created attachment 788611 [details]
File: backtrace

Comment 46 Pasi Karkkainen 2013-09-03 18:02:43 UTC
mate-display-properties still segfaults in Fedora 19 with mate-control-center-1.6.1-2.fc19.x86_64

Comment 47 chandrakant 2013-09-05 03:17:43 UTC
1 - I have problem with display since i installed fedora on Acer Iconia "dual screen laptop"
2 - I tried fedora 14, 17 and 19.
3 - Backlight of secondary screen is never on.
4 - There is a swtich to restart system, most of times pressing that switch turns on the backlight of secondary screen, otherwise i have to restsrt system.
5  - Sometimes system uses secondary screen as primary screen and one can not see anything but two blank screen, as secondary screen backlight is not turned on.
6 - pressing the restart switch before logging in to account, it restarts the system, problem 5 becomes bigger.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        mate-display-properties
crash_function: gdk_event_apply_filters
executable:     /usr/bin/mate-display-properties
kernel:         3.10.10-200.fc19.x86_64
package:        mate-control-center-1.6.1-2.fc19
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 48 Steve Howard 2013-09-13 16:17:45 UTC
Tried to change layout of monitors

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        mate-display-properties
crash_function: gdk_event_apply_filters
executable:     /usr/bin/mate-display-properties
kernel:         3.9.5-301.fc19.x86_64
package:        mate-control-center-1.6.1-2.fc19
reason:         Process /usr/bin/mate-display-properties was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 49 Aaron Lu 2013-12-23 08:08:32 UTC
It occurred when I change screen resolution in a vnc session

Comment 50 Aaron Lu 2013-12-23 08:11:27 UTC
It occurred when I change screen resolution in a vnc session: mate-control-center-1.6.1-3.fc19.x86_64

Comment 51 Dan Mashal 2013-12-23 19:58:10 UTC
Due to lack of upstream response, I am closing this bug. Please forward future comments on this issue to the link below and let them know you are having issues:

https://github.com/mate-desktop/mate-control-center/issues/48

Comment 52 leigh scott 2014-10-20 09:34:36 UTC
Reassigned to someone who cares

Comment 53 Wolfgang Ulbrich 2014-11-12 15:40:11 UTC

*** This bug has been marked as a duplicate of bug 1062796 ***


Note You need to log in before you can comment on or make changes to this bug.