Bug 9217 - Dutch dictionary called nederlands
Dutch dictionary called nederlands
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ispell (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 10167 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-08 08:38 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 09:36:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-02-08 08:38:25 EST
Hi, with the ispell-dutch package, the .hash and .aff files are installed
as nederlands.hash / .aff Nederlands is indeed the correct dutch word for
dutch, but some package expect to find dutch.hash when doing a dutch
spellcheck (lyx for example) so could you add symlinks called dutch.X to
nederlands.X ?
Comment 1 Trond Eivind Glomsrxd 2000-04-11 10:14:59 EDT
Isn't that more of a LyX bug?
Comment 2 Trond Eivind Glomsrxd 2000-04-11 12:28:59 EDT
*** Bug 10167 has been marked as a duplicate of this bug. ***
Comment 3 Hans de Goede 2000-04-12 07:06:59 EDT
I can sortoff agree on you but there seems to be no real concensus on wether
ispell dicts are in english or in the native language, I'm pretty sure for
example polish isn't polish in polish ;)

And there already is a germn symlink to deutsch.

So things are not standardised, so having symlinks to support both (or an alias
table if ispell supports such a thing) is probably best, or force a
standardisation for the 7.0 release.

If for example you look in /usr/share/locale/locale.alias, you will see dutch
there and not nederlands, this could be considered a bug, but there it is just
dutch. So how I'm I supposed to run a translated lyx with locale set to dutch,
and explain lyx that it should use nederlands as dictionary, kinda confusing.

Some other examples:
/usr/lib/kbd uses nl
/usr/X11R6/lib/xkb has neither dutch nor nl

So nederlands seems to be sorta the concensus, except that it is not a valid
locale, you could also argue that the real problem is that this data is just
kept in to many places, with to many different tables, but that is antoher
problem.
Comment 4 Trond Eivind Glomsrxd 2000-04-17 09:36:59 EDT
Try out the new ispell packages in the next Rawhide.

Note You need to log in before you can comment on or make changes to this bug.