Bug 92200 - XFree86 4.3 savage problem with vmware fullscreen mode
Summary: XFree86 4.3 savage problem with vmware fullscreen mode
Status: CLOSED DUPLICATE of bug 82551
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-03 19:49 UTC by Stefan Woerner
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Woerner 2003-06-03 19:49:01 UTC
Description of problem:
Having upgraded from RH 8.0 to RH 9 using vmware (VMwareWorkstation-4.0.0-4460)
in fullscreen mode is no longer possible, screen is corrupted like having a
problem with vertical refreshment. Problem is not related to vmware but to
XFree86 4.3 respectively the savage driver. Trying some options for the savage
driver the Option "UseBIOS" "off" made vmware usable in fullscreen mode again
having restarted the X server. But the next time I booted the Toshiba Tecra 8100
(S3 Savage MX) the X server was not able to start (black screen, no login
screen). The X server was available again having commented out the above
mentioned option and restarted the X server.
Only having started the X server without the option a restart with the option
makes the desktop usable (with vmware in fullscreen mode, too).

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. start X server with Option "UseBIOS" "off", no desktop
2. start X server without this option, always seems to be o.k., despite the
fullscreen problem of vmware
3. restart X server with this option having started the X server without this
option before (!)
    
Actual results:


Expected results:


Additional info:
Interestingly the savage driver files of XFree 4.2 (RH 8.0) work with XFree 4.3
but very slow and with some strange effect of the mouse cursor sometimes. vmware
4.0 fullscreen mode works properly.

Comment 1 Mike A. Harris 2003-06-04 09:26:27 UTC

*** This bug has been marked as a duplicate of 82551 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:53:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.