Bug 922452 - [patch] Remove bundled jar from build, update to upstream 3.4.2
Summary: [patch] Remove bundled jar from build, update to upstream 3.4.2
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-wtp-common
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Andrew Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-17 02:16 UTC by Gerard Ryan
Modified: 2013-03-21 21:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-21 21:43:36 UTC
Type: Bug


Attachments (Terms of Use)
git format-patch - fix mentioned issues (6.36 KB, patch)
2013-03-17 02:16 UTC, Gerard Ryan
no flags Details | Diff

Description Gerard Ryan 2013-03-17 02:16:59 UTC
Created attachment 711264 [details]
git format-patch - fix mentioned issues

Description of problem:
1. There's a jar downloaded with the sources, that's necessary for the build, even though it doesn't really do anything, and doesn't get included in the RPM at the end.

2. Upstream 3.4.2 is available, and upstream has moved from CVS to Git.

3. No tests are currently being run.


Steps to Reproduce:
1. See bundled jar file in current tarball eclipse-wtp-common-HEAD-fetched-src.tar.bz2
2. See that it isn't being removed in the spec before build.
  
Actual results:
Bad news.

Expected results:
Not bad news.

Additional info:
See attached git-formatted patch to fix these issues.

Comment 1 Gerard Ryan 2013-03-17 02:51:03 UTC
Fails to build on rawhide, but that seems to be a pdebuild problem rather than something specific to this package:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5131929

Works fine in f18:
https://koji.fedoraproject.org/koji/taskinfo?taskID=5131931

Comment 2 Gerard Ryan 2013-03-21 21:43:36 UTC
Patch applied (slightly modified - there seems to be an rpm macro for _eclipse_base in f18, but not rawhide).


Note You need to log in before you can comment on or make changes to this bug.