Bug 92255 - bad GRUB config when downgrading Kernel with RPM
bad GRUB config when downgrading Kernel with RPM
Status: CLOSED DUPLICATE of bug 60041
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 03:41 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-04 03:41:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Description of problem:
Yesterday I fetched the latest kernel RPM to upgrade my Redhat-9 installation. I
installed the kernel with RPM -F and everything went fine, except that on reboot
X did not run because the NVidia kernel module was out of sync. To reinstall the
NVidia module would require the kernel sources that I had not available just now.
No problem, the kernel upgrade was just for fun, not because of a real problem I
had encountered. The fix should be easy: just downgrade to the old kernel. rpm
-F doesnt do this, so I did rpm -e --nodeps kernel. This caused the first
problem: grubby complained that it could not find a valid template. The problem
persisted when I reinstalled the old kernel with rpm -i kernel....
Inspecting the grub.conf file revealed that there was no section for the 
kernel, so a reboot would fail. I fixed this by hand, but am still unable to
perform an automated kernel upgrade.
I think that this is bad behaviour:
1) There is no real need to touch the grub.conf file at all. Just set a link to
the kernel image that should be booted.
2) If the grub.conf file is touched for whatever reason, grub.conf should be
considered a config file that needs a backup.

Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. upgrade kernel with rpm -F kernel...rpm
2. uninstall kernel with rpm -e kernel
3. reinstall older kernel with rpm -i kernel...rpm
    

Actual Results:  damaged grub.conf file in /boot/grub

Expected Results:  valid grub.conf file

Additional info: none
Comment 1 Need Real Name 2003-06-05 02:05:53 EDT
Same problems here.
In my case it had even more annoying consequences. Even with a reconstructed
grub.conf file (I think I reconstructed it correctly), the machine won't boot.
It simply stops at "GRUB". I need to use now a boot disk. Do I need to
"revalidate" my grub configuration, somehow? (Something in the spirit of 'lilo -v')

I don't know how to get this repaired. I am a little bit afraid to update the
kernel now and discover that it only makes things worse...

Daniel
Comment 2 Jeremy Katz 2003-06-10 23:53:11 EDT

*** This bug has been marked as a duplicate of 60041 ***
Comment 3 Need Real Name 2003-06-11 02:46:56 EDT
I am glad to see that the problem has been identified but it does not solve the
consequences of this bug for me:
I have a non working GRUB because of an unsuccessful upgrade of the kernel (my /
partition was too small). I tried to recreate the grub.conf file (and I think I
did it right) but still, I can't reboot the machine. It says 'GRUB' and freezes.

What am I supposed to do?
Comment 4 Red Hat Bugzilla 2006-02-21 13:53:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.