Bug 92257 - ctags should use alternatives
ctags should use alternatives
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ctags (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 04:00 EDT by Marc MERLIN
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 03:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 2003-06-04 04:00:16 EDT
This was filed against emacs (bug #92256), but it would also require a rebuild
of the vim package to support /etc/alternatives

etags from emacs is apparently inferior to ctags from vim, except that many
systems (including the ones my engineers used to work on) have etags pointing
to vim's ctags.

Right now, I need to repoint /usr/bin/etags to vim's ctags.
I'm going to do mv etags etags.emacs, ln -s ctags etags

This is all nice and great, except that the next emacs upgrade is going to blow
my symlink away.
Of course, rpm should account for something like this, like I would do on 
debian with dpkg-divert etags etags.divert, but in the meantime, we can at
least repackage emacs and vim so that /usr/bin/etags is a symlink to
/etc/alternatives, like it is on debian.

gandalf:~$ l /usr/bin/etags 
lrwxrwxrwx    1 root     root           23 Aug 13  2002 /usr/bin/etags ->
/etc/alternatives/etags*
gandalf:~$ l /etc/alternatives/etags
lrwxrwxrwx    1 root     root           24 Aug 13  2002 /etc/alternatives/etags
-> /usr/bin/ctags-exuberant*
Comment 1 Jens Petersen 2004-09-29 02:01:49 EDT
Using alternatives for etags is fine.

(But AFAIK etags and ctags are not compatible at all
so symlinking etags to a ctags doesn't make much sense
to me.)
Comment 2 Jens Petersen 2004-09-29 02:08:24 EDT
I think you mean *ctags* "from emacs is apparently inferior to ctags
from" from ctags.  <nod/>  And the one in xemacs too...

So why do we need alternatives for ctags?
Comment 3 Jens Petersen 2004-09-29 02:09:15 EDT
Because it is better to have emacs's ctags than none?
Comment 4 Jens Petersen 2004-09-29 02:14:56 EDT
An alternative might be just not to ship ctags in emacs at all...

Currently we don't ship the xemacs one.
Comment 5 Jens Petersen 2004-09-29 02:18:53 EDT
Then again (sorry for so many comments),
perhaps this has changed but I noticed this comment
in emacs.spec:

* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
- Moved ctags to gctags to fit in the more powerful for C (but less
  general) exuberant ctags as the binary /usr/bin/ctags and the
  man page /usr/man/man1/ctags.1

If this is still the case, we should probably use alternatives
for ctags too...
Comment 6 Jens Petersen 2004-09-29 03:06:30 EDT
Actually that comment seems to completely out of date.

Additionally I note that adding alternatives to ctags
is non-trivial since rpm will delete the alternatives
link when upgrading from an older ctags package...

Note You need to log in before you can comment on or make changes to this bug.