Bug 92262 - bison skeleton does not compile as c++
bison skeleton does not compile as c++
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: bison (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
: 92377 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-04 06:07 EDT by Alexander Larsson
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.875-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 15:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2003-06-04 06:07:50 EDT
Building pwlib with bison-1.875-2 fails, because it uses the bison parser with g++.
The following code in yacc.c fails:

/*----------------------------------------------------.
| yyerrlab1 -- error raised explicitly by an action.  |
`----------------------------------------------------*/
yyerrlab1:

  /* Suppress GCC warning that yyerrlab1 is unused when no action
     invokes YYERROR.  */
#if defined (__GNUC_MINOR__) && 2093 <= (__GNUC__ * 1000 + __GNUC_MINOR__)
  __attribute__ ((__unused__))
#endif

]b4_location_if([  yylerrsp = yylsp;
  *++yylerrsp = yyloc;])[
  goto yyerrlab2;


since __attribute__ ((__unused__)) doesn't work in C++. I propose adding
!defined (_CPLUSPLUS_) or something.
Comment 1 Alexander Larsson 2003-06-04 06:08:48 EDT
(the attribute doesn't work for labels i mean)
Comment 2 Alexander Larsson 2003-06-04 06:13:50 EDT
(And i meant __cplusplus__ obviously)
Comment 3 Bill Nottingham 2003-07-24 18:49:06 EDT
*** Bug 92377 has been marked as a duplicate of this bug. ***
Comment 4 Roland McGrath 2003-09-24 15:42:22 EDT
hp committed the patch to fix C++ in the 1.875-3 rpm

Note You need to log in before you can comment on or make changes to this bug.