Bug 923359 - tar -W option causes errors
Summary: tar -W option causes errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar
Version: 6.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 963237 976553 (view as bug list)
Depends On:
Blocks: 1070830 1075802 1159820
TreeView+ depends on / blocked
 
Reported: 2013-03-19 16:17 UTC by Will Ellett
Modified: 2019-07-11 07:39 UTC (History)
8 users (show)

Fixed In Version: tar-1.23-12.el6
Doc Type: Bug Fix
Doc Text:
Previously, when the "--verify" or "-W" option was used, the tar utility always exited with a status of 2, and false warning messages per each archived file were printed. This behavior was a regression introduced in tar-1.23-11.el6. With this update, tar exits with a status of 2 only if there is a real problem with the archived files
Clone Of:
Environment:
Last Closed: 2015-07-22 06:13:19 UTC


Attachments (Terms of Use)
Example case of error (130.28 KB, image/png)
2013-03-19 16:17 UTC, Will Ellett
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1285 normal SHIPPED_LIVE tar bug fix update 2015-07-20 17:48:54 UTC
Red Hat Knowledge Base (Solution) 398503 None None None Never

Description Will Ellett 2013-03-19 16:17:00 UTC
Description of problem:
Upgrading from tar-1.23-7.el6.x86_64 to tar-1.23-11.el6.x86_64 introduced a problem with the -W verify switch. Problem seems to have started with tar-1.23-9.el6.x86_64 

Version-Release number of selected component (if applicable):
tar-1.23-7.el6.x86_64

How reproducible:
every time

Steps to Reproduce:
1. tar -cvWf mytarfile.tar *
  
Actual results:
file.txt: Mode differs
file.txt: Gid differs
file.txt: Mod time differs

Expected results:
Verify */file.txt

Additional info:
This is my first bug report.  Hopefully I am providing enough information.

Comment 1 Will Ellett 2013-03-19 16:17:39 UTC
Created attachment 712790 [details]
Example case of error

Comment 2 Will Ellett 2013-03-19 16:40:48 UTC
We tried to downgrade to tar-1.23-9.el6.x86_64 but the problem did not go away.  When we downgraded to tar-1.23-7.el6.x86_64 it went back to normal behavior.

Inspecting the tar file, the contents look correct.

Comment 3 Will Ellett 2013-03-19 16:42:37 UTC
Tested on two separate systems both running RHEL 6.4.  Also tested on mounted and local file systems with the same results.

Comment 4 Pavel Raiskup 2013-03-20 09:08:58 UTC
Hi Will, thanks for the report.  This is really caused by the RH-tar commit
a309347d41ac4 (longnames patch).  Upstream fixed this later by:

  http://git.savannah.gnu.org/cgit/tar.git/commit/?id=24214ca5d506f56

There are some other patches fixing/enhancing -W option which should be
observed in upstream but this should fix the major issue.

Note that this bug tracking system is not a mechanism for requesting support,
and we are not able to  guarantee the timeliness or suitability of a
resolution.

If this issue is critical or in any way time sensitive, please raise a ticket
through your regular Red Hat support channels to make certain it receives the
proper attention and prioritization to assure a timely resolution.

For information on how to contact the Red Hat production support team, please
visit:

  https://www.redhat.com/support/process/production/#howto

Pavel

Comment 5 Pavel Raiskup 2013-05-15 13:32:09 UTC
*** Bug 963237 has been marked as a duplicate of this bug. ***

Comment 7 Pavel Raiskup 2013-06-21 06:38:08 UTC
*** Bug 976553 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2015-07-22 06:13:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1285.html


Note You need to log in before you can comment on or make changes to this bug.