Bug 976553 - tar --verify / -W broken in current version (1.25)
Summary: tar --verify / -W broken in current version (1.25)
Keywords:
Status: CLOSED DUPLICATE of bug 923359
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Pavel Raiskup
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-20 19:01 UTC by Tru Huynh
Modified: 2013-06-21 06:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 723726
Environment:
Last Closed: 2013-06-21 06:38:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 6511 0 None None None Never

Description Tru Huynh 2013-06-20 19:01:38 UTC
+++ This bug was initially created as a clone of Bug #723726 +++

Description of problem:
Using tar --verify (or -W) to verify an archive after creating it fails.

Version-Release number of selected component (if applicable):
GNU tar 1.25

How reproducible:
Always, regardless of -p, etc.

Steps to Reproduce:
1. echo 'asdf' > temp
2. tar -cpvWf temp.tar temp
3. check exit status and output
  
Actual results:
temp
Verify temp
temp: Mode differs
temp: Uid differs
temp: Gid differs
temp: Mod time differs

return code: 1

Expected results:
Should verify w/out problems.

Additional info:
Apparently this was introduced in 1.24 and has been fixed upstream in 1.26. See 
http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00065.html
http://savannah.gnu.org/forum/forum.php?forum_id=6746

Would it be possible to switch to 1.26 or backport the fix to the current one?

--- Additional comment from Ondrej Vasik on 2011-07-22 01:25:56 EDT ---

Thanks for report and upstream info links.
Both possibilities... 1.26 is bugfix only release and it fixes more than just this one bug. In addition, 1.26 is in Rawhide for more than 4 months. 
On other hand - backport is small, just 2 lines (or ~20 if both related patches are taken). I'll do an update next week (I'm on vacation now).

--- Additional comment from Ved Vyas on 2011-07-23 17:10:42 EDT ---

Sounds good, thanks. Enjoy the rest of your vacation!

--- Additional comment from Fedora Update System on 2011-07-27 04:46:45 EDT ---

tar-1.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/tar-1.26-1.fc15

--- Additional comment from Fedora Update System on 2011-07-30 23:50:48 EDT ---

Package tar-1.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tar-1.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/tar-1.26-1.fc15
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2011-08-01 21:52:13 EDT ---

tar-1.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Ved Vyas on 2011-08-16 20:43:43 EDT ---

Sorry I couldn't leave karma on the update before it was pushed to stable. Looks like it works just fine now, thanks!

Comment 1 Pavel Raiskup 2013-06-21 06:38:08 UTC
Thanks for the report, it is known problem which will is treat in different
bugzilla.  Pavel

*** This bug has been marked as a duplicate of bug 923359 ***


Note You need to log in before you can comment on or make changes to this bug.