This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 923586 - Screen unlock (shield) fails on fresh F19 install
Screen unlock (shield) fails on fresh F19 install
Status: CLOSED DUPLICATE of bug 923364
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-20 02:38 EDT by Adam Williamson
Modified: 2013-03-20 05:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 05:07:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-03-20 02:38:28 EDT
My F19 live images have progressed to the point where I can build one that boots and installs - excellent. However, if I leave an installed F19 VM idle at a logged-in desktop until the screen blanks, then try to wake it up again, the screen stays blank. Switching to a VT works, and if I run 'DISPLAY=:0 gnome-shell --replace' , gnome-shell restarts and I can see the desktop again.

It looks like some kind of error in the screenShield.js code, according to a bunch of error messages I found in journalctl. The timestamps on these match up nicely with the attempt to unlock the screen; there are no similar messages before that time.

Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:02 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:02 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:02 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:02 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:02 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:03 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:04 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:04 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:04 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:04 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:34:04 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '611'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:611
Comment 1 Adam Williamson 2013-03-20 02:44:03 EDT
This is with gnome-shell-3.7.92-1.fc19.x86_64 .

On my 'dirty' desktop system I haven't noticed this, but then I just remembered, I don't have screen locking enabled. If I manually lock the screen, it goes black, moving the mouse wakes it up. I can't hit 'esc' to raise the shield (which I should be able to), but dragging it upward manually works, then I can enter the password and unlock okay.

If I manually lock the VM, I don't see the bug either, but I do see the 'esc doesn't work' bug. So it seems like the timeout is somehow significant to this bug...
Comment 2 Adam Williamson 2013-03-20 03:00:08 EDT
If I enable locking on my desktop, I can reproduce the bug there too, with the same JS ERRORs.
Comment 3 Adam Williamson 2013-03-20 04:46:38 EDT
I'm uploading my latest live image to assist in debugging this. It will be complete at:

http://fedorapeople.org/groups/qa/20130320-desktop-x86_64.iso

in approx. 50 minutes (it's currently there, but still uploading, so incomplete). sha256sum is:

38ffc3ca990f4d111f2e2e5c4a185358ef665f2bfaa9513b849102658a5e79d1
Comment 4 sangu 2013-03-20 04:59:27 EDT
Duplicated bug 923386 and bug 923364 ?
Comment 5 Adam Williamson 2013-03-20 05:07:28 EDT

*** This bug has been marked as a duplicate of bug 923364 ***

Note You need to log in before you can comment on or make changes to this bug.