Bug 9254 - GnoRPM dies behind firewall
GnoRPM dies behind firewall
Status: CLOSED DUPLICATE of bug 19057
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 2000-02-08 18:23 EST by david.hagood
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-22 10:00:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description david.hagood 2000-02-08 18:23:18 EST
At work I'm behind a firewall that does a standard HTTP authentication on
any access to an external site (to restrict access by "unauthorized
users"). This firewall cuts in both for transparent access as well as
non-transparent access (http_proxy environment var set).
In the case of transparent proxying, GnoRPM dies (segfault) on any attempt
to access the RedHat site (Web find, etc.)
In the case of non-transparent proxying, GnoRPM simply gives no
opportuntity to enter the username and password for the firewall
authentication, and so all web operations fail.
Comment 1 Alan Cox 2000-08-22 10:00:10 EDT
The crash case is fixed in the rawhide tree. Proxy may need more work
Comment 2 Alan Cox 2000-10-14 19:04:14 EDT

*** This bug has been marked as a duplicate of 19057 ***

Note You need to log in before you can comment on or make changes to this bug.