Bug 927315 - kickstart install stop at installation prompt, no disks selected
kickstart install stop at installation prompt, no disks selected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 927621 (view as bug list)
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-25 11:59 EDT by Orion Poplawski
Modified: 2013-04-30 00:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 00:39:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (9.94 KB, image/png)
2013-03-25 11:59 EDT, Orion Poplawski
no flags Details
storage.log (25.95 KB, text/plain)
2013-03-25 12:00 EDT, Orion Poplawski
no flags Details
anaconda.log (1.71 KB, text/plain)
2013-03-25 12:01 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2013-03-25 11:59:35 EDT
Created attachment 716080 [details]
screenshot

Description of problem:

Kickstart install on vm with :

install
text
url --url=http://fedora.cora.nwra.com/development/19/x86_64/os
repo --name=rpmfusion-free-development-19-x86_64 --baseurl=http://rpmfusion.cora.nwra.com/free/fedora/development/19/x86_64/os 
repo --name=rpmfusion-nonfree-development-19-x86_64 --baseurl=http://rpmfusion.cora.nwra.com/nonfree/fedora/development/19/x86_64/os 
repo --name=cora-f19-x86_64 --baseurl=http://corpms.cora.nwra.com/fedora/19/x86_64 
repo --name=adobe-linux-x86_64 --baseurl=http://adobe.cora.nwra.com/linux/x86_64/ 
repo --name=adobe-linux-i386 --baseurl=http://adobe.cora.nwra.com/linux/i386/ 

lang en_US.UTF-8
keyboard us
rootpw --iscrypted xxxx
firewall --disabled
firstboot --disable
selinux --enforcing
timezone --utc America/Denver
xconfig --startxonboot --defaultdesktop=KDE
clearpart --all --initlabel
part biosboot --fstype=biosboot --size=1
part / --size=3000 --grow
part swap --recommended
zerombr
bootloader --location=mbr
network --bootproto=dhcp --device=eth0 --onboot=on
reboot

Stops at Installation prompt with:
2) [!] Install Destination
       (No disks selected)

Version-Release number of selected component (if applicable):
19.13
Comment 1 Orion Poplawski 2013-03-25 12:00:36 EDT
Created attachment 716082 [details]
storage.log
Comment 2 Orion Poplawski 2013-03-25 12:01:30 EDT
Created attachment 716085 [details]
anaconda.log
Comment 3 Orion Poplawski 2013-03-25 12:17:21 EDT
I can manually select vda for the install destination via the menu fine.
Comment 4 Martin Banas 2013-03-26 07:35:13 EDT
*** Bug 927621 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2013-03-27 10:47:10 EDT
The key here is that you have not specified an ignoredisk line, which is what the storage spokes are looking at to determine whether you've completed partitioning or not.  Given that command is not required, we need to make the spokes smarter.
Comment 6 Richard Marko 2013-04-08 11:04:37 EDT
What is the workaround in this case? Using ignoredisk doesn't seem to help.
I've tried ignoredisk --drives=vda and ignoredisk --only-use=vda.
Comment 7 Martin Banas 2013-04-11 05:13:40 EDT
Hi Chris,
any update on this bug? This is currently blocking us from automated testing.
Comment 8 Orion Poplawski 2013-04-16 15:52:57 EDT
Interesting that this only appears to happen on "vd" disks, not "sd".
Comment 9 Fedora Update System 2013-04-22 21:39:02 EDT
anaconda-19.21-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.21-1.fc19
Comment 10 Fedora Update System 2013-04-22 23:01:44 EDT
Package anaconda-19.21-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.21-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6338/anaconda-19.21-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-04-24 12:38:36 EDT
Package anaconda-19.21-1.fc19, python-meh-0.23-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.21-1.fc19 python-meh-0.23-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6338/python-meh-0.23-1.fc19,anaconda-19.21-1.fc19
then log in and leave karma (feedback).
Comment 12 Matthew Miller 2013-04-29 09:20:20 EDT
There is a workaround for this issue: it will work in graphics mode. So, simply remove the line "text" from your kickstart temporarily.
Comment 13 Fedora Update System 2013-04-30 00:39:25 EDT
anaconda-19.21-1.fc19, python-meh-0.23-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.