Bug 9274 - Networking stops working after system is up for a couple of hours
Summary: Networking stops working after system is up for a couple of hours
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-09 19:20 UTC by doug.kratky
Modified: 2014-01-23 09:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 02:35:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description doug.kratky 2000-02-09 19:20:30 UTC
Everything works fine for a while after reboot.  After some amount of time
(less than a couple of hours), networking stops working.  Can't ping any
remote IP addresses by name or address.  Other systems on network (e.g.,
Solaris, NT., etc. are fine).

When problem happens, "netstat -in" output, ifconfig output, all looks
okay.  If I do "ifconfig eth0 down" and then "ifconfig eth0 up", then
networking starts working again.

Comment 1 Riley H Williams 2000-02-09 19:58:59 UTC
Is this on a machine with an AMD processor? If so, it could be connected with
one of my systems with an AMD K6-2/350 processor that also locks up after a
couple of hours.

Comment 2 mark.seminatore 2000-02-25 05:17:59 UTC
See my bug #6258. I have a number of machines locking up.  Thought it was the
NICS, replace em but it still happens.  I suspect SMP now and am running stock
2.2.12.  I have reports that ifconfig eth0 down up restored connectivity.

Comment 3 mark.seminatore 2000-02-25 05:19:59 UTC
Sorry, it was bug #9258.

Comment 4 dch 2000-02-27 07:50:59 UTC
I have a similar problem on two identical machines on different
networks, both stock redhat 6.1 installs with p-III and 3c509c
cards.  They stop talking through the gateway but can talk to
machines on the local network.  If left alone they will start
talking outbound after a random amount of time (10-60 minutes or
so).  If I drop the default route and add it back they start talking
to the gateway.  I'm not sure if it's the kernel since I have
6.0 machines that I've upgraded to 2.2.12 and don't have that
problem.


Note You need to log in before you can comment on or make changes to this bug.