Bug 927625 - No mirrorlist available during kickstart installation
No mirrorlist available during kickstart installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 980647 (view as bug list)
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-26 07:26 EDT by Martin Banas
Modified: 2013-07-05 13:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 09:54:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (5.50 KB, text/plain)
2013-03-26 07:29 EDT, Martin Banas
no flags Details
ifcfg.log (318 bytes, text/plain)
2013-03-26 07:29 EDT, Martin Banas
no flags Details
packaging.log (18.28 KB, text/plain)
2013-03-26 07:29 EDT, Martin Banas
no flags Details
program.log (17.29 KB, text/plain)
2013-03-26 07:29 EDT, Martin Banas
no flags Details
screenshot.png (58.39 KB, image/png)
2013-03-26 07:29 EDT, Martin Banas
no flags Details
storage.log (101.72 KB, text/plain)
2013-03-26 07:30 EDT, Martin Banas
no flags Details
storage.state (20.00 KB, application/octet-stream)
2013-03-26 07:30 EDT, Martin Banas
no flags Details
syslog (75.13 KB, text/plain)
2013-03-26 07:30 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2013-03-26 07:26:34 EDT
Description of problem:
If I start kickstart installation, and do not specify url to the repository in kickstart, anaconda won't use mirrorlist. I'm sure this worked in F18, but now it only prints "Nothing selected". (see screenshot)

Version-Release number of selected component (if applicable):
Fedora 19-Alpha-TC2
anaconda-19.13

How reproducible:
always

Steps to Reproduce:
1. Start installation with following kickstart file:
bootloader --location=mbr
zerombr
clearpart --all --initlabel
part / --fstype=ext4 --size=7000
rootpw redhat
graphical
timezone Europe/Prague
install
reboot
lang en_US
keyboard us

  
Actual results:
Anaconda complains that no installation source is selected.

Expected results:
Anaconda should use closest mirror as it does during manual installation.

Additional info:
Comment 1 Martin Banas 2013-03-26 07:29:46 EDT
Created attachment 716451 [details]
anaconda.log
Comment 2 Martin Banas 2013-03-26 07:29:49 EDT
Created attachment 716452 [details]
ifcfg.log
Comment 3 Martin Banas 2013-03-26 07:29:52 EDT
Created attachment 716453 [details]
packaging.log
Comment 4 Martin Banas 2013-03-26 07:29:55 EDT
Created attachment 716454 [details]
program.log
Comment 5 Martin Banas 2013-03-26 07:29:58 EDT
Created attachment 716455 [details]
screenshot.png
Comment 6 Martin Banas 2013-03-26 07:30:01 EDT
Created attachment 716456 [details]
storage.log
Comment 7 Martin Banas 2013-03-26 07:30:05 EDT
Created attachment 716457 [details]
storage.state
Comment 8 Martin Banas 2013-03-26 07:30:08 EDT
Created attachment 716458 [details]
syslog
Comment 9 Chris Lumens 2013-03-26 09:54:32 EDT
If that's how it worked in F18, then F18 was wrong.  Kickstart installs should stop and prompt you for any information you did not provide.  Since you didn't provide any installation method, we need to ask you for one.  That's how all the other commands work.
Comment 10 Martin Banas 2013-03-26 10:08:08 EDT
Is there something in kickstart file to specify closest mirror? I don't see anything on anaconda/kickstart wiki.
Comment 11 David Shea 2013-07-05 13:47:26 EDT
*** Bug 980647 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.