Bug 928287 - anaconda crashing to black screen at end of Fedora 19 Alpha install
anaconda crashing to black screen at end of Fedora 19 Alpha install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 928838 947666 (view as bug list)
Depends On:
Blocks: F19Alpha/F19AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-03-27 06:14 EDT by Mike FABIAN
Modified: 2013-04-08 23:38 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-08 23:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tmp-log.tar.gz (85.64 KB, application/x-gzip)
2013-03-27 06:14 EDT, Mike FABIAN
no flags Details
/tmp/syslog (84.22 KB, text/plain)
2013-03-27 08:05 EDT, Mike FABIAN
no flags Details
/tmp/syslog (84.22 KB, text/plain)
2013-03-27 08:08 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-03-27 06:14:36 EDT
Created attachment 716993 [details]
tmp-log.tar.gz

I try to  install Fedora-19-Alpha-TC2-x86_64-DVD.iso in qemu.

qemu started with:

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 4 -drive file=./Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2-output.log -name Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-19-Alpha-TC2/Fedora-19-Alpha-TC2-x86_64-DVD.iso -boot c -vga std -display sdl -net nic -net user,hostname=Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,hostfwd=tcp::5560-:22 -monitor stdio -usb

I do a minimal install in US English
(the same problem seems to happen with the default Gnome install
as well, I just used minimal here to reproduce it faster)

- At the first screen I accept the selected English and just click "next"
- At the screen with the spokes I choose to install on the whole disk
  and select "Minimal Install" in the software selection and change the
  timezone to Europe/Berlin.

- start the installation.
- now I can enter a passwort for root and create a user, it does not
  seem to matter whether I do this or just wait.

- after all the packages are installed, the screen becomes black.

- switching to a VT shows that anaconda is dead (“Pane is dead”)

This happens almost always, I tried many times and one time
the minimal install actually finished and I could report bug#927564

/tmp/*.log files attached.
Comment 1 Mike FABIAN 2013-03-27 07:44:05 EDT
<msivak> can you try it with qxl driver?

I tried a minimal install in English twice using

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 4 -drive file=./Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2-output.log -name Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-19-Alpha-TC2/Fedora-19-Alpha-TC2-x86_64-DVD.iso -boot c -vga qxl -display sdl -net nic -net user,hostname=Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,hostfwd=tcp::5560-:22 -monitor stdio -usb

and it worked both times.
Comment 2 Mike FABIAN 2013-03-27 08:05:35 EDT
Created attachment 717041 [details]
/tmp/syslog

<vpodzime> mfabian: can you get the /tmp/syslog file in case of another crash?

Reproduce the crash and attached syslog.
Comment 3 Mike FABIAN 2013-03-27 08:08:18 EDT
Created attachment 717042 [details]
/tmp/syslog

<vpodzime> mfabian: can you get the /tmp/syslog file in case of another crash?

Reproduce the crash and attached syslog.
Comment 4 Vratislav Podzimek 2013-03-27 08:39:45 EDT
from the end of the /tmp/syslog file:
> 11:49:08,750 NOTICE dbus: [system] Successfully activated service org.freedesktop.locale1'
> 11:49:08,751 INFO systemd: Started Locale Service.

I've seen some crashes happening when Anaconda tried to talk to systemd-localed over DBus. I guess this is the same case.
Comment 5 Mike FABIAN 2013-03-29 08:18:31 EDT
It seems to happen with all video drivers, that it worked twice with qxl
(comment#2) was just luck.
Comment 6 Mike FABIAN 2013-03-29 08:20:39 EDT
bug#928838 might be a duplicate.
Comment 7 Jens Petersen 2013-03-29 08:48:17 EDT
*** Bug 928838 has been marked as a duplicate of this bug. ***
Comment 8 Vratislav Podzimek 2013-03-29 08:53:56 EDT
Mike, could you please try this updates image?

http://vpodzime.fedorapeople.org/928287_updates.img

(by adding "updates=http://vpodzime.fedorapeople.org/928287_updates.img" to command line)

This crash happens when Anaconda tries to talk to systemd-localed over DBus from a non-main thread.
Comment 9 Jens Petersen 2013-03-29 10:00:16 EDT
This happened to me with TC3 net install on bare metal (bug 928838).
Comment 10 Vratislav Podzimek 2013-03-29 10:52:56 EDT
(In reply to comment #9)
> This happened to me with TC3 net install on bare metal (bug 928838).
It is not not specific to virtual machines. But it is probably some kind of race condition because it doesn't happen every time so maybe it happens on virtual machines more often.
Comment 11 Adam Williamson 2013-03-30 00:23:12 EDT
If the installed system is actually functional, then the install has been completed, and I'd probably be -1 on this as a blocker...
Comment 12 Mike FABIAN 2013-03-30 12:38:09 EDT
(In reply to comment #11)
> If the installed system is actually functional, then the install has been
> completed, and I'd probably be -1 on this as a blocker...

The installed system is not functional, when rebooting after the screen becomes
black, the system does not boot.
Comment 13 Mike FABIAN 2013-03-31 13:25:49 EDT
(In reply to comment #8)
> Mike, could you please try this updates image?
> 
> http://vpodzime.fedorapeople.org/928287_updates.img
> 
> (by adding "updates=http://vpodzime.fedorapeople.org/928287_updates.img" to
> command line)
> 
> This crash happens when Anaconda tries to talk to systemd-localed over DBus
> from a non-main thread.

I tried it 5 times with the above updates images and it worked every time.

Then I tried again 2 times without the updates images and the error was there.

So I think the update it helps.

(I tried with Fedora-19-Alpha-TC3-x86_64-DVD.iso)
Comment 14 Rahul Sundaram 2013-03-31 19:33:29 EDT
Yep,  I can confirm the fix as well.
Comment 15 Vratislav Podzimek 2013-04-01 09:13:50 EDT
Thanks a lot for testing, guys. Unfortunately the fix in the updates.img was not a nice thing to do. But it proved where the problem lies. Could you please try a new updates.img with a nicer and more versatile patch [1]? It works for me. If it also works in your cases, we will have a winner. :) Otherwise I'll go with the previous fix for Alpha and think about something better for later versions.

[1] http://vpodzime.fedorapeople.org/928287_updates_new.img
Comment 16 Mike FABIAN 2013-04-02 01:36:23 EDT
(In reply to comment #15)
> Thanks a lot for testing, guys. Unfortunately the fix in the updates.img was
> not a nice thing to do. But it proved where the problem lies. Could you
> please try a new updates.img with a nicer and more versatile patch [1]? It
> works for me. If it also works in your cases, we will have a winner. :)
> Otherwise I'll go with the previous fix for Alpha and think about something
> better for later versions.
> 
> [1] http://vpodzime.fedorapeople.org/928287_updates_new.img

I tried this new fix Fedora-19-Alpha-TC3-x86_64-DVD.iso and it
worked for me 2 times.
Comment 17 Jens Petersen 2013-04-02 05:47:01 EDT
928287_updates_new.img also worked for me.
Comment 18 Vratislav Podzimek 2013-04-02 06:22:35 EDT
Great! Thanks a lot, guys! I've posted patches to anaconda-patches.
Comment 19 Kamil Páral 2013-04-03 07:16:36 EDT
(In reply to comment #11)
> If the installed system is actually functional, then the install has been
> completed, and I'd probably be -1 on this as a blocker...

I have hit this problem as well, hard rebooted the computer, and the system boots (it was a minimal install), but the root password is different from what I've set. It probably didn't sync properly. I guess the system might be in a somewhat broken state.
Comment 20 Kamil Páral 2013-04-03 07:49:36 EDT
(In reply to comment #19)
> I have hit this problem as well, hard rebooted the computer, and the system
> boots (it was a minimal install), but the root password is different from
> what I've set. It probably didn't sync properly. I guess the system might be
> in a somewhat broken state.

According to Vratislav the same code is also run before installing the booloader, so sometimes even the bootloader is not installed.
Comment 21 Adam Williamson 2013-04-03 12:26:34 EDT
Discussed at 2013-04-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-03/f19alpha-blocker-review-4.2013-04-03-16.01.log.txt . Accepted as a blocker per criterion "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." - this criterion is used for showstopper bugs like this, as the install did not 'complete'.

Can we please have a new build of anaconda with this fix in it ASAP, anaconda team? bcl, sorry I asked for a new build last night without specifying that we need this fix in it :(
Comment 22 Adam Williamson 2013-04-03 12:29:30 EDT
*** Bug 947666 has been marked as a duplicate of this bug. ***
Comment 23 Shawn Starr 2013-04-03 22:52:32 EDT
I only saw this behavior when trying to use TC3 Anaconda to install Fedora 18 mirror. This happened on physical HW vs KVM also.
Comment 24 Adam Williamson 2013-04-04 13:37:37 EDT
Vratislav, could you do an updates.img against TC4 with your fix? I had to request TC4 without this fix, but it'd be good if we could use an updates.img to get around it for further testing.
Comment 25 Fedora Update System 2013-04-04 20:51:16 EDT
anaconda-19.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.16-2.fc19
Comment 26 satellitgo 2013-04-04 21:12:50 EDT
saw this on dd USB TC4 netinstallx86_64 to MacBookPro i7 EFI boot. Screen went black at end of install
Comment 27 Jens Petersen 2013-04-04 23:37:22 EDT
Live TC4 x86_64 install on bare metal with anaconda-19.16-2.fc19 succeeded . :)
Comment 28 Vratislav Podzimek 2013-04-05 04:49:49 EDT
(In reply to comment #24)
> Vratislav, could you do an updates.img against TC4 with your fix? I had to
> request TC4 without this fix, but it'd be good if we could use an
> updates.img to get around it for further testing.

http://vpodzime.fedorapeople.org/928287_updates_tc4.img

TC5 should have a new anaconda with the patch applied.
Comment 29 Reartes Guillermo 2013-04-05 13:04:05 EDT
I tried F19a TC5 on a physical system usually ended in the black screen (and non-bootable TC3/TC4) and installed ok. No black screen. I was able to finally install F19a TC5 on that system.
Comment 30 Adam Williamson 2013-04-05 15:18:59 EDT
Marking as VERIFIED, please upkarma the anaconda update, thanks!
Comment 31 Jens Petersen 2013-04-06 00:36:27 EDT
(BTW for the record it seems the crashes were mostly (only?) happening
with smp ie on systems with multiple cpu's.)
Comment 32 Vratislav Podzimek 2013-04-08 09:07:03 EDT
(In reply to comment #31)
> (BTW for the record it seems the crashes were mostly (only?) happening
> with smp ie on systems with multiple cpu's.)
Thanks for the additional info it may be a huge help in some future cases, because I'm afraid this can happen in any other project using Python dbus module and multiple threads.
Comment 33 Fedora Update System 2013-04-08 23:38:53 EDT
anaconda-19.16-2.fc19, python-meh-0.22-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.