Bug 928323 - Pidgin crashed while opening
Summary: Pidgin crashed while opening
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin-sipe
Version: 18
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Stefan Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-27 12:19 UTC by Artur Cuvasov
Modified: 2013-04-20 19:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-20 01:17:00 UTC


Attachments (Terms of Use)
Pidgin backtrace log (3.58 KB, application/gzip)
2013-03-27 12:19 UTC, Artur Cuvasov
no flags Details

Description Artur Cuvasov 2013-03-27 12:19:10 UTC
Created attachment 717046 [details]
Pidgin backtrace log

Description of problem:
Pidgin crashes when you run it.

Version-Release number of selected component (if applicable):
2.10.7-2.fc18 (libpurple 2.10.7)

How reproducible:
Every time.

Steps to Reproduce:
1. Run pidgin with sipe-based default profile


Additional info:
A ticket has been opened in pidgin bug ticketing system, however they claim it is the issue in sipe plugin.

https://developer.pidgin.im/ticket/15568

Comment 1 Stefan Becker 2013-03-27 12:32:32 UTC
The bug entry and backtrace doesn't contain enough information for me to work on this issue. I only see one function referenced from SIPE source code (sip-transport.c:1592) but without a version information I can't match it up the the source code visible to me.

- what is the version number of pidgin-sipe RPM installed on your machine?
- did you maybe compile pidgin-sipe yourself? If yes what release version or git commit?
- if you are not using latest 1.15.0 package from F18, can you reproduce the problem after upgrading?
- if you can still reproduce it with 1.15.0, can you provide a backtrace from a non-optimized version? E.g.

  $ tar xf pidgin-sipe-1.15.0.tar.bz2
  $ cd pidgin-sipe-1.15.0
  $ CFLAGS="-g -O0" ./configure
  $ make
  -> install the generated libsipe.so as root

- if you can still reproduce it in the previous step, can you try to reproduce it the latest git HEAD?

and PLEASE PLEASE PLEASE run "pidgin --debug" and attach the log output too, so that I have some context where the crash actually happens.

Comment 2 Artur Cuvasov 2013-03-27 12:41:08 UTC
Name        : pidgin-sipe
Version     : 1.15.0
Release     : 1.fc18

Comment 3 Artur Cuvasov 2013-03-27 12:42:08 UTC
I forgot to mention it here... pidgin -d runs without any issues.

Comment 4 Stefan Becker 2013-03-27 12:48:15 UTC
(In reply to comment #3)
> I forgot to mention it here... pidgin -d runs without any issues.

This will make this difficult to debug. What is the log output without -d? And please try to reproduce with the non-optimized version.

Comment 5 Artur Cuvasov 2013-03-27 12:57:15 UTC
I have sent you "with -d" by mail . Without it's just:

Pidgin 2.10.7-2.fc18 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

Comment 6 Artur Cuvasov 2013-03-27 13:46:31 UTC
A short summary of what we have discussed by mail:

Recompilation did not show any problematic areas. I am able to run "pidgin -n", and then log in manually. Pidgin does not crash. It only crashes when pidgin is trying to connect automatically after I run it.

At the moment I downgraded to purple-sipe and pidgin-sipe 1.13.3, as the problem appeared after upgrading to 1.15.0

Comment 7 Stefan Becker 2013-03-27 15:59:02 UTC
Pushed proposed fix for inclusion in 1.15.1 release. Please verify.

commit 6a33b7452fbaedcb70cc08d2afa3272271b4903f
Author: Stefan Becker <chemobejk@gmail.com>
Date:   Wed Mar 27 17:47:28 2013 +0200

    transport: fix use-after-free accesses
    
    This is a proposed fix for the Heisenbug crash reported here:
    
       https://bugzilla.redhat.com/show_bug.cgi?id=928323
    
    Valgrind log showed invalid read/write accesses to the already freed
    transport data structures in the following cases:
    
    - sip: during redirect
    - http: potentially on server initiated close
    - http: on user initiated close
    
    With this patch my valgrind log no longer shows any invalid accesses
    from the SIP/HTTP input routines.

Comment 8 Artur Cuvasov 2013-03-29 08:55:52 UTC
The patch has solved the issue, pidgin does not crash anymore.

Comment 9 Fedora Update System 2013-04-07 13:25:12 UTC
pidgin-sipe-1.15.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.15.1-1.fc19

Comment 10 Fedora Update System 2013-04-07 13:26:58 UTC
pidgin-sipe-1.15.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.15.1-1.fc18

Comment 11 Fedora Update System 2013-04-07 13:27:59 UTC
pidgin-sipe-1.15.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.15.1-1.fc17

Comment 12 Fedora Update System 2013-04-07 17:34:06 UTC
Package pidgin-sipe-1.15.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pidgin-sipe-1.15.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5094/pidgin-sipe-1.15.1-1.fc19
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-04-20 01:17:01 UTC
pidgin-sipe-1.15.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-04-20 01:18:00 UTC
pidgin-sipe-1.15.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-04-20 19:33:12 UTC
pidgin-sipe-1.15.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.