Bug 947429 - consumed entitlements are not deleted,when the subscription is deleted at server side
Summary: consumed entitlements are not deleted,when the subscription is deleted at ser...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel510
TreeView+ depends on / blocked
 
Reported: 2013-04-02 11:57 UTC by Shwetha Kallesh
Modified: 2013-09-30 23:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2013-09-30 23:05:18 UTC


Attachments (Terms of Use)
Detailed description (14.63 KB, application/octet-stream)
2013-04-02 11:57 UTC, Shwetha Kallesh
no flags Details
Removal of subscription after the subscription is deleted (14.68 KB, text/plain)
2013-06-14 12:13 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 22:49:24 UTC

Description Shwetha Kallesh 2013-04-02 11:57:08 UTC
Created attachment 730727 [details]
Detailed description

Description of problem:
consumed entitlements are not deleted,when the subscription is deleted at server side

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a subscription and refresh the pools
2.attach the created subscription
3.delete the created subscription and refresh the pools again
4.restart rhsmcertd service

PS: attachment for details
  
Actual results:
consumed subscriptions are not removed

Expected results:
Consumed subscriptions should be removed

Additional info:

Comment 1 RHEL Product and Program Management 2013-04-29 17:17:13 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 2 William Poteat 2013-06-05 15:22:28 UTC
I repeated this test. It took 5-10 minutes on a restart of rhsmcertd, but the entitlement was revoked.

Please confirm and give it some time to succeed.

Comment 3 Shwetha Kallesh 2013-06-14 12:13:26 UTC
Created attachment 761235 [details]
Removal of subscription after the subscription is deleted

Not working for me,details in the attachment

[root@rhel64 entitlement]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.13-1
subscription-manager: 1.8.10-1.el6
python-rhsm: 1.8.12-1.el6

Comment 4 William Poteat 2013-07-08 19:22:01 UTC
[root@rhel64 entitlement]# service rhsmcertd restart
Stopping rhsmcertd...                                      [  OK  ]
Starting rhsmcertd...                                      [  OK  ]

>>>>>> How long did you wait here? This is where you wait.

[root@rhel64 entitlement]# subscription-manager list --consumed

Comment 5 Shwetha Kallesh 2013-07-24 09:02:36 UTC
Marking verified!!

[root@client64vm ~]# subscription-manager version
server type: RHN Classic and Red Hat Subscription Management
subscription management server: 0.8.17-1
subscription-manager: 1.8.10-1.el5
python-rhsm: 1.8.12-1.el5


[root@client64vm ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: test_products
Provides:          test_products
SKU:               90001
Contract:          610642068
Account:           2115437683
Serial:            1322439292815984532
Pool ID:           8ac6a3a2400fdfa801400fe3df791479
Active:            True
Quantity Used:     1
Service Level:     
Service Type:      
Status Details:    
Starts:            04/01/2013
Ends:              08/17/2013


[root@client64vm ~]# date
Wed Jul 24 14:24:19 IST 2013

[root@client64vm ~]# service rhsmcertd restart
Stopping rhsmcertd...                                      [  OK  ]
Starting rhsmcertd...                                      [  OK  ]

[root@client64vm ~]# date
Wed Jul 24 14:32:00 IST 2013

[root@client64vm ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Comment 7 errata-xmlrpc 2013-09-30 23:05:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html


Note You need to log in before you can comment on or make changes to this bug.