Bug 947536 - Use of qxl video results in crash of F19 vm
Summary: Use of qxl video results in crash of F19 vm
Keywords:
Status: CLOSED DUPLICATE of bug 952666
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-02 16:54 UTC by Robert Lightfoot
Modified: 2013-04-18 07:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-18 07:37:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Lightfoot 2013-04-02 16:54:57 UTC
Description of problem:
Boot F19 anaconda installer with qxl driver and get crash-reboot as anaconda loads

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. USe Virtual Machine Manager to create VM and attach F19-Alpha-TC3-DVD.iso as CD drive
2. Select Install to HD at initial menu
3. When loading first kernel VM will crash-reboot
  
Actual results:
Crash to Power Off State

Expected results:
Anaconda gui installer should be presented

Additional info:
Logs of Bad and good VM
BAD:
2013-04-02 16:38:43.950+0000: starting up
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name F19-i386-testbox -S -M rhel6.4.0 -cpu qemu32 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid 81946d0d-4c0f-c1c0-ce9a-c026317ab1a3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/F19-i386-testbox.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/var/lib/libvirt/images/F19-i386-testbox.img,if=none,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/bob/isos/Fedora-19-Alpha-TC3-i386-DVD.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:38:2c:52,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
char device redirected to /dev/pts/6
main_channel_link: add main channel client
main_channel_handle_parsed: net test: invalid values, latency 0 roundtrip 1646. assuming highbandwidth
inputs_connect: inputs channel client create
red_dispatcher_set_cursor_peer: 
((null):3299): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0
2013-04-02 16:39:55.179+0000: shutting down

GOOD:
2013-04-02 16:43:28.619+0000: starting up
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name F19-i386-testbox -S -M rhel6.4.0 -cpu qemu32 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid 81946d0d-4c0f-c1c0-ce9a-c026317ab1a3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/F19-i386-testbox.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/var/lib/libvirt/images/F19-i386-testbox.img,if=none,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/bob/isos/Fedora-19-Alpha-TC3-i386-DVD.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:38:2c:52,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
char device redirected to /dev/pts/6
main_channel_link: add main channel client
main_channel_handle_parsed: net test: invalid values, latency 0 roundtrip 572. assuming highbandwidth
inputs_connect: inputs channel client create
red_dispatcher_set_cursor_peer:

Comment 1 Adam Williamson 2013-04-02 17:15:27 UTC
can you see what happens with a TC3 live image, out of interest?

Comment 2 Robert Lightfoot 2013-04-02 18:35:44 UTC
will take a while to do that as I don't have any downloaded.  Starting the download now on my 1024mb DSL -- give me a day or two thanks.

Comment 3 Robert Lightfoot 2013-04-02 23:00:48 UTC
Fedora-19-Alpha-TC3-i686-Live-Desktop produces the following log and fails to start as well when using the qxl driver.
2013-04-02 22:58:30.207+0000: starting up
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=spice /usr/libexec/qemu-kvm -name F19-i386-testbox -S -M rhel6.4.0 -cpu qemu32 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid 81946d0d-4c0f-c1c0-ce9a-c026317ab1a3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/F19-i386-testbox.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/var/lib/libvirt/images/F19-i386-testbox.img,if=none,id=drive-virtio-disk0,format=raw,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/bob/isos/Fedora-19-Alpha-TC3-i686-Live-Desktop.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0,vhost=on,vhostfd=24 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:38:2c:52,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
char device redirected to /dev/pts/6
main_channel_link: add main channel client
main_channel_handle_parsed: net test: latency 0.398000 ms, bitrate 5936231884 bps (5661.231884 Mbps)
inputs_connect: inputs channel client create
red_dispatcher_set_cursor_peer: 
((null):30587): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0
2013-04-02 22:59:08.751+0000: shutting down

Comment 5 Gerd Hoffmann 2013-04-18 07:37:23 UTC

*** This bug has been marked as a duplicate of bug 952666 ***


Note You need to log in before you can comment on or make changes to this bug.