Bug 952666 - RHEL-7/F-19 does not work on 6.4 qemu-kvm + spice: assert "red_create_surface: Untested path stride >= 0" failed
Summary: RHEL-7/F-19 does not work on 6.4 qemu-kvm + spice: assert "red_create_surface...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Desktop QE
URL:
Whiteboard:
: 947536 964305 976204 (view as bug list)
Depends On: 952671
Blocks: 973703
TreeView+ depends on / blocked
 
Reported: 2013-04-16 11:59 UTC by Gerd Hoffmann
Modified: 2013-11-21 07:40 UTC (History)
16 users (show)

Fixed In Version: spice-server-0.12.0-14.el6
Doc Type: Bug Fix
Doc Text:
Previously, qemu-kvm terminated with the following error message, "((null):3635): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0." The spice-server did not allow creation of a surface with "stride >= 0," as this path of code was untested, and no qxl driver did this before. On some systems, spice-server terminated when the qxl driver tried creating a surface with the "stride >= 0" path. With this update, spice-server no longer checks for the "stride >=0" path, and VMs with qxl devices are able to run and use their qxl driver.
Clone Of:
Environment:
Last Closed: 2013-11-21 07:40:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1571 normal SHIPPED_LIVE spice-server bug fix and enhancement update 2013-11-20 21:39:57 UTC

Description Gerd Hoffmann 2013-04-16 11:59:15 UTC
Description of problem:
qemu-kvm aborts with this message:
((null):3635): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0

Version-Release number of selected component (if applicable):
spice-server-0.12.0-12.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
Boot Fedora 19 Alpha live iso in qemu-kvm, with -vga qxl
  
Additional info:
<hans>
So we would need to add:
http://cgit.freedesktop.org/spice/spice/commit/?id=2c85436dc6c2e9febecfb84c579e7a50a4a6bd6b 
</hans>

Comment 1 Gerd Hoffmann 2013-04-18 07:37:23 UTC
*** Bug 947536 has been marked as a duplicate of this bug. ***

Comment 2 Robert Lightfoot 2013-04-18 09:38:27 UTC
Can someone explain to me how 947536 created 2013-04-02 12:54:57 is a duplicate of 952666 created 2013-04-16 07:59:15.  I work mostly with Industrial Controls Software and Linux is only a hobby, but usually the newer is a duplicate of the older not the other way round.  At least I hope this gets it addressed.

Comment 3 Christophe Fergeau 2013-04-18 09:50:08 UTC
Robert, it's usually done the way you describe it, but in this case, this bug has a link to a patch fixing the bug, so it makes more sense to keep the bug with this link open, and to close the other one as a duplicate.

Comment 4 Robert Lightfoot 2013-04-18 09:56:16 UTC
Thanks CHristopher I missed the patch link since it was in the text and not in the attachments sections.

Comment 5 Robert Lightfoot 2013-04-19 18:54:25 UTC
So this Patch -{http://cgit.freedesktop.org/spice/spice/commit/?id=2c85436dc6c2e9febecfb84c579e7a50a4a6bd6b}- is to an *.c file which means the maitnainer now needs to incorporate and issue an update rpm.  IIRC.

Comment 6 Robert Lightfoot 2013-04-20 15:13:23 UTC
I just deconstructed the spice-server rpm I am using and this patch is in there and still spice does not work with F19.

Comment 7 Robert Lightfoot 2013-05-03 22:37:37 UTC
Fedora 19-Beta-TC2 and Centos 6.4 with full updates are still imcompatable if qxl driver is used for video.

Comment 8 Christophe Fergeau 2013-05-17 19:57:38 UTC
*** Bug 964305 has been marked as a duplicate of this bug. ***

Comment 10 Uri Lublin 2013-05-19 09:47:04 UTC
I applied Alon's patch.
This seems to solve the problem.
Fedora 19 guest now comes (but very slowly).

Comment 11 Christophe Fergeau 2013-05-21 09:31:46 UTC
Do we want this in 6.4.z as well?

Comment 12 Robert Lightfoot 2013-05-24 01:40:23 UTC
I am still seeing this bug in Centos 6.4 with F19-Beta-RC4, but I suspect that is because Centos 6 is using spice-server-0.12.0-12.el6.  I have not found a 0.12.0-14.el6 rpm or src.rpm to date.

Comment 13 Robert Lightfoot 2013-05-24 12:33:22 UTC
I also appllied Alon's patch to spice-server-0.12.0-12 and F19 with qxl driver now works on Centos 6.4 aka RHEL 6.4

Comment 14 Paul Vine 2013-05-28 12:02:24 UTC
QE can ack this when Fedora is added as a requirement for Spice. Please talk to Product Management.

Comment 15 David Blechter 2013-05-28 12:11:46 UTC
proposing for 6.4.z after the problem in comment 14 will be addressed.

Comment 21 Hans de Goede 2013-05-29 10:32:50 UTC
Since RHEL-7 is following F-19 quite close atm, any problems with F-19 will also impact RHEL-7, updating the Summary to reflect this.

Comment 23 Paul Vine 2013-05-30 17:10:23 UTC
QE ca not reproduce the problem as reported with RHEL 7.0 builds from May 22 or May 29.

Comment 24 Paul Vine 2013-06-12 11:28:52 UTC
Now reproducible on RHEL 7.0, adding QE ack.

Comment 27 Petr Spacek 2013-06-18 07:36:44 UTC
I confirm that package spice-server-0.12.0-14.el6.x86_64 (brew build 273061, SHA1sum a1f5e9336a9bbfd5ea16f899e0362a02fa7745ec) fixed the problem in our development lab.

Comment 28 Christophe Fergeau 2013-06-20 07:33:23 UTC
*** Bug 976204 has been marked as a duplicate of this bug. ***

Comment 31 errata-xmlrpc 2013-11-21 07:40:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1571.html


Note You need to log in before you can comment on or make changes to this bug.