Bug 948228 - AttributeError: 'noneType' object has no attribute 'convertTo'
AttributeError: 'noneType' object has no attribute 'convertTo'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 949991 (view as bug list)
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-04-04 07:12 EDT by Ľuboš Kardoš
Modified: 2013-05-29 20:50 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-19.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 20:50:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback (280.00 KB, application/octet-stream)
2013-04-04 07:13 EDT, Ľuboš Kardoš
no flags Details
anaconda traceback (753.82 KB, application/octet-stream)
2013-04-04 07:15 EDT, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2013-04-04 07:12:34 EDT
Description of problem:
When you don't fill desidered capacity during creating of mountpoint, unknown error occurs.

Version-Release number of selected component (if applicable):
F19-Alpha-TC4
anaconda 19.15

How reproducible:
always

Steps to Reproduce:
1. Start installation and proceed to the "MANUAL PARTITIONING" spoke.
2. Click on plus to create mount point.
3. Create mountpoint "/" and don't fill desidered capacity.
  
Actual results:
Unknow error occurs. Traceback is attached.

Expected results:
No error should occur. Anaconda can inform you to fill "Desidered Capacity" or set default value (e.g. all available capacity like in previous releases).

Additional info:
Comment 1 Ľuboš Kardoš 2013-04-04 07:13:14 EDT
Created attachment 731534 [details]
anaconda traceback
Comment 2 Ľuboš Kardoš 2013-04-04 07:15:12 EDT
Created attachment 731535 [details]
anaconda traceback
Comment 3 Ladislav Jozsa 2013-04-09 09:26:49 EDT
*** Bug 949991 has been marked as a duplicate of this bug. ***
Comment 4 Tim Flink 2013-04-09 13:44:05 EDT
Description of problem:
In the custom partitioning screen, I attempted to create a partition without specifying the size

Version-Release number of selected component:
anaconda-19.16-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz inst.stage2=hd:UUID=075E-CF79 nomodeset
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1674, in on_add_clicked
    if dialog.size.convertTo(spec="mb") < 1:
AttributeError: 'NoneType' object has no attribute 'convertTo'
Comment 5 Fedora Update System 2013-04-09 18:57:35 EDT
python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19
Comment 6 Ľuboš Kardoš 2013-04-10 03:10:50 EDT
Verified on anaconda-19.17-1 (Fedora 19 RC2).
Comment 7 Jeff Bastian 2013-04-11 14:15:18 EDT
Description of problem:
I added a /boot mount point and anaconda crashed.

Version-Release number of selected component:
anaconda-19.16-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1674, in on_add_clicked
    if dialog.size.convertTo(spec="mb") < 1:
AttributeError: 'NoneType' object has no attribute 'convertTo'
Comment 8 Adam Williamson 2013-05-29 20:50:51 EDT
This was verified fixed in 19.17 and we're way past that in stable: closing. (c#7 was still with 19.16).

Note You need to log in before you can comment on or make changes to this bug.