Bug 949991 - AttributeError: 'NoneType' object has no attribute 'convertTo'
AttributeError: 'NoneType' object has no attribute 'convertTo'
Status: CLOSED DUPLICATE of bug 948228
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0429fd5720b48aa5c1601c7c82b...
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-04-09 08:38 EDT by Ladislav Jozsa
Modified: 2013-04-09 09:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 09:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (695.10 KB, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: anaconda.log (15.84 KB, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: backtrace (252 bytes, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: environ (780 bytes, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: ifcfg.log (842 bytes, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: lsblk_output (1.47 KB, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: nmcli_dev_list (6.63 KB, text/plain)
2013-04-09 08:38 EDT, Ladislav Jozsa
no flags Details
File: packaging.log (330.11 KB, text/plain)
2013-04-09 08:39 EDT, Ladislav Jozsa
no flags Details
File: program.log (31.28 KB, text/plain)
2013-04-09 08:39 EDT, Ladislav Jozsa
no flags Details
File: storage.log (86.17 KB, text/plain)
2013-04-09 08:39 EDT, Ladislav Jozsa
no flags Details
File: syslog (85.66 KB, text/plain)
2013-04-09 08:39 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2013-04-09 08:38:29 EDT
Description of problem:
This error popped up after adding / partition while not speciying amount of disk space to be reserved.
The following was filed automatically by anaconda:
anaconda 19.16-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1674, in on_add_clicked
    if dialog.size.convertTo(spec="mb") < 1:
AttributeError: 'NoneType' object has no attribute 'convertTo'

Version-Release number of selected component:
anaconda-19.16-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1674, in on_add_clicked
    if dialog.size.convertTo(spec="mb") < 1:
AttributeError: 'NoneType' object has no attribute 'convertTo'
Comment 1 Ladislav Jozsa 2013-04-09 08:38:36 EDT
Created attachment 733194 [details]
File: anaconda-tb
Comment 2 Ladislav Jozsa 2013-04-09 08:38:42 EDT
Created attachment 733195 [details]
File: anaconda.log
Comment 3 Ladislav Jozsa 2013-04-09 08:38:45 EDT
Created attachment 733196 [details]
File: backtrace
Comment 4 Ladislav Jozsa 2013-04-09 08:38:47 EDT
Created attachment 733197 [details]
File: environ
Comment 5 Ladislav Jozsa 2013-04-09 08:38:49 EDT
Created attachment 733198 [details]
File: ifcfg.log
Comment 6 Ladislav Jozsa 2013-04-09 08:38:56 EDT
Created attachment 733199 [details]
File: lsblk_output
Comment 7 Ladislav Jozsa 2013-04-09 08:38:58 EDT
Created attachment 733200 [details]
File: nmcli_dev_list
Comment 8 Ladislav Jozsa 2013-04-09 08:39:02 EDT
Created attachment 733202 [details]
File: packaging.log
Comment 9 Ladislav Jozsa 2013-04-09 08:39:07 EDT
Created attachment 733203 [details]
File: program.log
Comment 10 Ladislav Jozsa 2013-04-09 08:39:09 EDT
Created attachment 733204 [details]
File: storage.log
Comment 11 Ladislav Jozsa 2013-04-09 08:39:12 EDT
Created attachment 733205 [details]
File: syslog
Comment 12 Ladislav Jozsa 2013-04-09 09:26:49 EDT

*** This bug has been marked as a duplicate of bug 948228 ***

Note You need to log in before you can comment on or make changes to this bug.