Bug 948331 - Kickstart installation using autopart doesn't work
Kickstart installation using autopart doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 948090 950169 (view as bug list)
Depends On:
Blocks: fedora19rtt F19PPCAlpha/F19PPCAlphaBlocker/PPCAlphaBlocker
  Show dependency treegraph
 
Reported: 2013-04-04 11:25 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-19.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 13:06:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart (181 bytes, application/octet-stream)
2013-04-04 11:26 EDT, Ľuboš Kardoš
no flags Details
anaconda.log (276.57 KB, text/x-log)
2013-04-04 11:27 EDT, Ľuboš Kardoš
no flags Details
packaging.log (13.23 KB, text/x-log)
2013-04-04 11:28 EDT, Ľuboš Kardoš
no flags Details
programl.log (1012.25 KB, text/x-log)
2013-04-04 11:28 EDT, Ľuboš Kardoš
no flags Details
storage.log (5.39 MB, text/x-log)
2013-04-04 11:29 EDT, Ľuboš Kardoš
no flags Details
anaconda.log file after a kickstart install using F19 Beta (17.75 KB, text/plain)
2013-05-30 12:48 EDT, ajs
no flags Details
storage.log file after a kickstart install using F19 Beta (306.61 KB, text/plain)
2013-05-30 12:51 EDT, ajs
no flags Details

  None (edit)
Description Ľuboš Kardoš 2013-04-04 11:25:18 EDT
Description of problem:
Kickstart installation using autopart doesn't work.

Version-Release number of selected component (if applicable):
F19-Alpha-TC4
anaconda 19.15

How reproducible:
always

Steps to Reproduce:
1. Start kickstart installation with attached kickstart.
  
Actual results:
Anaconda will stop in main hub and text under label "INSTALLATION DESTINATION" is switching from "No disk selected" to "Failed to save storage configuration" and back to "No disk selected" in loop again and again. 


Expected results:
Succesful installation.

Additional info:
Comment 1 Ľuboš Kardoš 2013-04-04 11:26:46 EDT
Created attachment 731647 [details]
kickstart
Comment 2 Ľuboš Kardoš 2013-04-04 11:27:40 EDT
Created attachment 731648 [details]
anaconda.log
Comment 3 Ľuboš Kardoš 2013-04-04 11:28:30 EDT
Created attachment 731649 [details]
packaging.log
Comment 4 Ľuboš Kardoš 2013-04-04 11:28:58 EDT
Created attachment 731651 [details]
programl.log
Comment 5 Ľuboš Kardoš 2013-04-04 11:29:52 EDT
Created attachment 731652 [details]
storage.log
Comment 6 Fedora Update System 2013-04-09 18:57:17 EDT
python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19
Comment 7 Ľuboš Kardoš 2013-04-10 04:17:55 EDT
Verified on anaconda-19.17-1 (Fedora 19 RC2).
Comment 8 Chris Lumens 2013-04-11 14:32:10 EDT
*** Bug 948090 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2013-04-15 09:07:15 EDT
*** Bug 950169 has been marked as a duplicate of this bug. ***
Comment 10 Robert Lightfoot 2013-04-19 20:06:39 EDT
This bug still exists in F19-Alpha-i386-RC4-DVD
Comment 11 Robert Lightfoot 2013-04-19 20:11:25 EDT
Bug 948090 shows the ks with autopart directive being used and isntall stops at main menu and acts like no disk was chosen.
Comment 12 Robert Lightfoot 2013-04-19 20:37:39 EDT
Turns out --all must be in clearpart directive for this not be a problem on previously populated disks.
Comment 13 ajs 2013-05-25 15:03:59 EDT
Between F19 Alpha and F19 Beta RC4, this quit working even if clearpart --all is specified.

The following quit working for me between those two versions

ignoredisk --only-use=sda
clearpart --all --initlabel --drives=sda
autopart --encrypted --type=plain --passphrase=${DISK_PASSPHRASE}
Comment 14 Adam Williamson 2013-05-29 22:40:06 EDT
What do you mean by 'quit working', exactly?
Comment 15 ajs 2013-05-30 12:46:48 EDT
Sorry for the hasty report.

Anaconda used to clear all of the partitions on sda and install F19 on that drive with the partitioning scheme chosen by 'autopart'

Now, Anaconda waits at the main hub claimimg that it doesn't have anywhere to install to.  When I select the disk spoke, everything is already selected properly, but I have to reclaim the space on sda.

See the attached anaconda.log-ajsfedora-Beta

The six minute break between lines 138 and 139 is just me reclaiming the disk space on sda and accepting all of the settings from the kickstart file.

I'm going through the storage.log file for privacy and I'll upload it in a few minutes.
Comment 16 ajs 2013-05-30 12:48:01 EDT
Created attachment 754966 [details]
anaconda.log file after a kickstart install using F19 Beta
Comment 17 ajs 2013-05-30 12:51:34 EDT
Created attachment 754977 [details]
storage.log file after a kickstart install using F19 Beta
Comment 18 Adam Williamson 2013-05-30 13:06:46 EDT
Ah, that sounds rather like another bug we've been looking at, currently under https://bugzilla.redhat.com/show_bug.cgi?id=967527 but probably going to be split out from it. I think we can close this one, but please follow up there.
Comment 19 ajs 2013-05-30 13:24:20 EDT
I'm running an install from F19-Alpha to collect the logs.  Should I post those logs there or here?

Note You need to log in before you can comment on or make changes to this bug.