Bug 948615 - Konqueror fails QA:Testcase_Desktop_Browser -- fails to allow access to FAS2 even with valid credentials
Summary: Konqueror fails QA:Testcase_Desktop_Browser -- fails to allow access to FAS2 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-baseapps
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 949129 (view as bug list)
Depends On:
Blocks: F19Alpha, F19AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2013-04-04 19:58 UTC by Robert Lightfoot
Modified: 2013-04-09 03:42 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-09 03:42:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Lightfoot 2013-04-04 19:58:53 UTC
Description of problem:
Website presents welcome message and login

Version-Release number of selected component (if applicable):
19-alpha-tc4

How reproducible:
100%

Steps to Reproduce:
1. Install KDE Default setup
2. open conqueror
3. goto fas2 login page
  
Actual results:
continuous cycle of login and no fail message but no login

Expected results:
successful login

Additional info:

Comment 1 Adam Williamson 2013-04-04 22:27:24 UTC
can you check it works from a 'known good' browser/OS combo? I'll see if I can reproduce the problem...did you install from live, netinst or DVD? thanks!

Comment 2 Rex Dieter 2013-04-04 23:16:35 UTC
triaging to kde-baseapps component (where konqueror lives).

Fwiw, I can't reproduce the problem on my f18 box with same kde/konqueror version, so *may* be f19 specific somehow.  Been meaning to get a fresh f19 install going, may as well be now.

Comment 3 Robert Lightfoot 2013-04-05 08:16:13 UTC
I performed this test on 8 arch-DE combinations and it worked 50% of the time as follows:
F19-Alpha-TC3-i386 Gnome-Firefox -- Worked
F19-Alpha-TC3-x86_64 Gnome-Firefox -- Worked
F19-Alpha-TC4-i386 Gnome-Firefox -- Worked
F19-Alpha-TC4-x86_64 Gnome-Firefox -- Worked
F19-Alpha-TC3-i386 KDE-Konqueror -- Failed
F19-Alpha-TC3-x86_64 KDE-Konqueror -- Failed
F19-Alpha-TC4-i386 KDE-Konqueror -- Failed
F19-Alpha-TC4-x86_64 KDE-Konqueror -- Failed

Comment 4 Martin Krizek 2013-04-05 08:22:15 UTC
Confirming the issue. I can reproduce it on F19 Alpha TC4. However, as Rex mentions, it works on F18 with same version of kde-baseapps - kde-baseapps-4.10.1-1.

Comment 5 Martin Krizek 2013-04-05 08:31:06 UTC
For completeness, this violates the following criterion:

"It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments.

The web browser must be able to download files, load extensions (if applicable), and log into FAS."

Comment 6 Martin Krizek 2013-04-05 11:48:57 UTC
Interesting note: I can't reproduce the issue in live environment. Seems it affects only installed system. Tested on both TC4 and T5.

Comment 7 Robert Lightfoot 2013-04-05 12:50:30 UTC
Also worth noting, Firefox when installed on KDE will reach FAS2 site ok.  Konqueror still does not.

Comment 8 Rex Dieter 2013-04-05 14:01:03 UTC
Those of you testing installed F19, is this with any updates installed or not?

(if updates installed, I'd argue the cause could be something currently in -testing possibly causing this, then it's not a blocker)

Comment 9 Jaroslav Reznik 2013-04-05 14:30:35 UTC
Another possibility how to avoid blocking on this issue is KHTML engine - could you please try to switch to KHML? View -> View Mode -> KHTML and retry? At least we could say it's Konqueror bug or QtWebKit one.

Comment 10 nucleo 2013-04-05 16:30:06 UTC
Problem with kded4 appears on installed systems but not on live image.

kded4: symbol lookup error: /usr/lib/kde4/kded_kscreen.so: undefined symbol: _ZN7KScreen6Output14setCurrentModeEi
kio_http(1138)/kio_http_debug HTTPProtocol::findCookies: Can't communicate with kded_kcookiejar!

Comment 11 Kevin Kofler 2013-04-05 16:53:31 UTC
Looks like mismatched kscreen and libkscreen, resulting in kded4 not loading, and thus NO kded4 service loading, including kcookiejar.

Comment 12 Fedora Update System 2013-04-05 17:04:36 UTC
kscreen-0.0.81-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kscreen-0.0.81-1.fc19

Comment 13 Adam Williamson 2013-04-05 18:44:30 UTC
Whaddayaknow, that ridiculous test case caught a legitimate bug? Amazing.

Comment 14 Robert Lightfoot 2013-04-05 20:13:19 UTC
Rex can't speak for others but my testing is done on fresh from DVD installs.

Comment 15 Adam Williamson 2013-04-05 20:59:56 UTC
+1 blocker based on criterion cited in comment #5. Can others please give blocker votes on this so we can pull it into TC6/RC1? Thanks!

Comment 16 Kevin Fenzi 2013-04-05 21:08:45 UTC
+1 blocker here.

Comment 17 Tim Flink 2013-04-05 21:30:38 UTC
+1 blocker based on the criterion cited in comment #5. That makes for +3 blocker, moving it to accepted

Comment 18 Fedora Update System 2013-04-06 05:15:43 UTC
Package kscreen-0.0.81-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kscreen-0.0.81-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5007/kscreen-0.0.81-1.fc19
then log in and leave karma (feedback).

Comment 19 Rex Dieter 2013-04-06 10:22:53 UTC
*** Bug 949129 has been marked as a duplicate of this bug. ***

Comment 20 Robert Lightfoot 2013-04-06 18:38:45 UTC
kscreen-0.0.81-1.fc19 and a reboot resolved the issue for me.

Comment 21 Robert Lightfoot 2013-04-07 02:50:18 UTC
I have tested with F19-Alpha-TC5 both i386 and x86_64 installs.  Test Procedure as follows:
1.  Wait for GUI Install to reach <REBOOT> point.
2.  Switch to text tty with <CTRL><ALT><F2>
3.  chroot /mnt/sysimage
4.  yum update kscreen --enablerepo=updates-testing
5.  Respond as needed to yum and let it complete
6.  Reboot the System.

Saw the following results:
In both arch it works

Comment 22 Martin Krizek 2013-04-08 07:42:41 UTC
kscreen-0.0.81-1.fc19 fixes the issue for me as well.

Comment 23 Fedora Update System 2013-04-09 03:42:45 UTC
kscreen-0.0.81-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.