Bug 948741 - problems updating moodle from 2.1.10 to 2.2.x
problems updating moodle from 2.1.10 to 2.2.x
Status: CLOSED DUPLICATE of bug 947252
Product: Fedora EPEL
Classification: Fedora
Component: moodle (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-05 05:52 EDT by Michael Young
Modified: 2013-04-05 10:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 10:20:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2013-04-05 05:52:04 EDT
There are several problems updating a moodle install from from moodle-2.1.10-1.el6.noarch to moodle-2.2.9-1.el6.noarch (or 2.2.7-1.el6)

Updating the RPM fails with the error
error: unpacking of archive failed on file /var/www/moodle/web/lib/pear/HTML/QuickForm: cpio: rename

and if you manually delete /var/www/moodle/web/lib/pear/HTML/QuickForm first (so it can create the symlink) you get the similar error

error: unpacking of archive failed on file /var/www/moodle/web/lib/pear/OLE: cpio: rename

If you likewise work around this then upgrading the data gets as far as the 
Course overview plugin and then quits with the error (when debugging is turned on)

Warning: require_once(HTML/QuickForm/DHTMLRulesTableless.php): failed to open stream: No such file or directory in /var/www/moodle/web/lib/formslib.php on line 44 Fatal error: require_once(): Failed opening required 'HTML/QuickForm/DHTMLRulesTableless.php' (include_path='/var/www/moodle/web/lib/zend:/var/www/moodle/web/lib/pear:.:/usr/share/pear:/usr/share/php') in /var/www/moodle/web/lib/formslib.php on line 44

so the php-pear-HTML-QuickForm package is missing DHTMLRulesTableless.php (also Renderer/Tableless.php) which moodle uses.
Comment 1 Jon Ciesla 2013-04-05 10:20:25 EDT

*** This bug has been marked as a duplicate of bug 947252 ***

Note You need to log in before you can comment on or make changes to this bug.