This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 947252 - Moodle does not work because PHP error: Cannot redeclare class dml_exception
Moodle does not work because PHP error: Cannot redeclare class dml_exception
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: moodle (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
: 948741 976229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-01 19:24 EDT by Milan Kerslager
Modified: 2013-08-01 16:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: moodle-2.3.8-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 21:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2013-04-01 19:24:05 EDT
In moodle-2.2.7-1.el6.noarch I was hit by bug which prevent running Moodle web interface with "Cannot redeclare class dml_exception" error.

PHP Fatal error:  require_once(): Cannot redeclare class dml_exception in /var/www/moodle/web/lib/setup.php on line 449

The solution is to use moodle-2.2.9-1.el6.noarch from testing repo by (and then run upgrade process in Moodle itself):

yum update --enablerepo=epel-testing moodle

If it works for you, please leave karma at https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0800/moodle-2.2.9-1.el6 to allow pushing to stable repo.
Comment 1 Milan Kerslager 2013-04-01 20:25:27 EDT
There is at least one missing file in testing moodle update I mentioned above:

lib/pear/HTML/QuickForm/DHTMLRulesTableless.php

So the update should not be recommended for 2.2.9-1.el6 version.
Comment 2 Jon Ciesla 2013-04-05 10:20:25 EDT
*** Bug 948741 has been marked as a duplicate of this bug. ***
Comment 3 Jon Ciesla 2013-07-12 11:39:29 EDT
*** Bug 976229 has been marked as a duplicate of this bug. ***
Comment 4 Jon Ciesla 2013-07-12 11:44:30 EDT
Does simply copying in DHTMLRulesTableless.php restore functionality?  If not, I'll have to get a bundling exception for this from FPC.
Comment 5 Michael Young 2013-07-12 13:06:24 EDT
Yes, if you return that file (I think you need HTML/QuickForm/Renderer/Tableless.php as well) moodle will do things such as updating. Long term, the right solution is for upstream moodle to update their bundled version of QuickForm which doesn't need these workarounds but putting these files back will get moodle working again in the short term.
Comment 6 Jon Ciesla 2013-07-12 13:15:40 EDT
Filed: https://tracker.moodle.org/browse/MDL-40644

I'll look into a short-term fix.
Comment 7 Jon Ciesla 2013-07-12 13:47:54 EDT
See how this works for you.

http://fedorapeople.org/~limb/moodle/moodle-2.3.8-1.el6.noarch.rpm
Comment 8 Michael Young 2013-07-12 14:42:49 EDT
(In reply to Jon Ciesla from comment #7)
> See how this works for you.
> 
> http://fedorapeople.org/~limb/moodle/moodle-2.3.8-1.el6.noarch.rpm

Yes I can upgrade to that successfully.
Comment 9 Jon Ciesla 2013-07-12 15:27:44 EDT
Excellent, I'll get that right out, as well as fixing this on the Fedora branches.
Comment 10 Fedora Update System 2013-07-12 15:41:28 EDT
moodle-2.3.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/moodle-2.3.8-1.el6
Comment 11 Fedora Update System 2013-07-13 16:14:26 EDT
Package moodle-2.3.8-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing moodle-2.3.8-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10839/moodle-2.3.8-1.el6
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-07-18 10:08:02 EDT
moodle-2.3.8-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-12950/moodle-2.3.8-2.fc18
Comment 13 Fedora Update System 2013-07-18 10:29:09 EDT
moodle-2.2.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/moodle-2.2.11-1.fc17
Comment 14 Fedora Update System 2013-07-20 05:38:43 EDT
Package moodle-2.2.11-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing moodle-2.2.11-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13252/moodle-2.2.11-1.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-07-22 21:07:44 EDT
moodle-2.3.8-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-07-30 13:43:34 EDT
moodle-2.2.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-08-01 16:43:23 EDT
moodle-2.3.8-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.