Bug 949640 - [RFE] Client tools should pass up CPU Socket information
Summary: [RFE] Client tools should pass up CPU Socket information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Stephen Herr
QA Contact: Martin Korbel
URL:
Whiteboard:
: 949639 (view as bug list)
Depends On: 596917 948326 948335
Blocks: 960054 sat560-splice 948337 949615 949617 949619 949620 949622 949623 993073 993076
TreeView+ depends on / blocked
 
Reported: 2013-04-08 17:04 UTC by Stephen Herr
Modified: 2019-07-11 07:40 UTC (History)
18 users (show)

Fixed In Version: rhn-client-tools-1.0.0.1-8-el6
Doc Type: Enhancement
Doc Text:
* While Satellite 5.3.0 now has the ability to get the number of CPUs via an API call, there was no function to obtain the number of sockets from the registered systems. This update adds a function to get the number of physical CPU sockets in a managed system from Satellite via an API call.
Clone Of: 948326
Environment:
Last Closed: 2013-07-17 09:24:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1087 normal SHIPPED_LIVE rhn-client-tools bug fix and enhancement update 2013-07-17 13:22:32 UTC

Description Stephen Herr 2013-04-08 17:04:54 UTC
+++ This bug was initially created as a clone of Bug #948326 +++

+++ This bug was initially created as a clone of Bug #596917 +++

Bug 596917 describes the desire to have CPU Socket information available from Satellite. This requires two different logical steps.

1) The RHEL client tools must be updated to pass socket information to Satellite
2) Satellite must be updated to store / display socket information

This bug will track the development and release of #1, the client tools portion. Bug 596917 will track the development and release of #2, the Satellite portion. Both will be necessary for this functionality to work.

Comment 1 Stephen Herr 2013-04-29 12:54:56 UTC
*** Bug 949639 has been marked as a duplicate of this bug. ***

Comment 5 Martin Korbel 2013-06-26 07:54:47 UTC
VERIFIED on Satellite-5.6.0-RHEL6-re20130607.1
Satellite:
 - spacewalk-java-1.9.83-42.el6sat
 - spacewalk-schema-1.9.38-17.el6sat
 - spacewalk-backend-1.9.46-18.el6sat

Client RHEL 6.4 x86_64:
 - rhn-setup-1.0.0.1-4.el6 or older (empty field)
 - rhn-setup-1.0.0.1-8.el6 or newer (it shows correct number of socket)

Comment 7 errata-xmlrpc 2013-07-17 09:24:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1087.html


Note You need to log in before you can comment on or make changes to this bug.